Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226272 - Merge Review: perl-Net-SSLeay
Summary: Merge Review: perl-Net-SSLeay
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:36 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-16 06:59:03 UTC
panemade: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 20:36:59 UTC
Fedora Merge Review: perl-Net-SSLeay

http://cvs.fedora.redhat.com/viewcvs/devel/perl-Net-SSLeay/
Initial Owner: wtogami@redhat.com

Comment 1 Parag AN(पराग) 2007-10-26 11:20:13 UTC
1)perl as BR is not needed. mock build without it worked successfully.
   remove redundant dependency on perl
2)you may like to keep simple disttag as "5%{dist}" only.


Comment 2 Parag AN(पराग) 2007-11-13 08:53:23 UTC
Warren,
  Can you please update SPEC and build package?

Comment 3 Parag AN(पराग) 2007-11-16 06:59:03 UTC
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
b0cd6c1681bbc0695d81be5cd852d1d0  Net_SSLeay.pm-1.30.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Package perl-Net-SSLeay-1.30-7.fc9 ->
  Provides: SSLeay.so perl(Net::SSLeay) = 1.30 perl(Net::SSLeay::Handle) = 0.61
  Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.4) libcrypto.so.6 libssl.so.6 perl >= 0:5.005_03
perl(:MODULE_COMPAT_5.8.8) perl(AutoLoader) perl(Carp) perl(DynaLoader)
perl(Errno) perl(Exporter) perl(Net::SSLeay) perl(Socket) perl(strict)
perl(vars) rtld(GNU_HASH)

APPROVED.



Note You need to log in before you can comment on or make changes to this bug.