Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226270 (perl-Net-DNS) - Merge Review: perl-Net-DNS
Summary: Merge Review: perl-Net-DNS
Keywords:
Status: CLOSED NOTABUG
Alias: perl-Net-DNS
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:36 UTC by Nobody's working on this, feel free to take it
Modified: 2012-08-10 13:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-24 03:25:05 UTC
jochen: fedora-review+


Attachments (Terms of Use)
log of failed mock build (deleted)
2007-04-03 17:00 UTC, Jochen Schmitt
no flags Details

Description Nobody's working on this, feel free to take it 2007-01-31 20:36:43 UTC
Fedora Merge Review: perl-Net-DNS

http://cvs.fedora.redhat.com/viewcvs/devel/perl-Net-DNS/
Initial Owner: rnorwood@redhat.com

Comment 1 Jochen Schmitt 2007-04-03 16:59:07 UTC
Good:
+ Rpmlint quite on source rpm
+ Tar ball matches with upstream.
+ License ok.
+ Local build works fine.
+ Rpmlint quite for binary package
+ Rpmlint quite for debuginfo package.


Bad:
- Wrong Buildroot:
uildRoot should be %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  (wiki: PackagingGuidelines#BuildRoot)
- Perl must not be included as an BR.
BuildRequires: perl should not be included
  (wiki: Packaging/Guidelines#Exceptions)
- Package contains no verbatin copy of the license text.
- Mock build failed






Comment 2 Jochen Schmitt 2007-04-03 17:00:15 UTC
Created attachment 151589 [details]
log of failed mock build

Comment 3 Paul Howarth 2007-04-03 17:07:58 UTC
Can you post the root.log as well? I'm curious as to how the buildreq
perl-Net-IP was satisfied since the absence of this module is what caused the
build to fail.

(the perl-Net-IP buildreq should really be perl(Net::IP) of course)

Comment 4 Robin Norwood 2007-04-05 18:10:39 UTC
o Fixed the buildroot

------

This string is in the README:

"""
All rights reserved.  This program is free software; you may redistribute
it and/or modify it under the same terms as Perl itself.
"""

Which is sufficient for perl packages - the text of the license doesn't have to
be included unless it is included in the source tarball.

-------

o I can't reproduce the build failure you show maybe the root.log that Paul
requests in comment #3 will help.

o Fixed the BuildRequires - removed 'perl', and changed the others to the
perl(Module::Name) format.

-------

0.59-2.fc7 should fix these issues - if the mock build failure is geniune, we
can look at the root.log and maybe figure out what's up.

Comment 5 Jochen Schmitt 2007-05-22 14:58:53 UTC
Good:
+ Rpmlint quite on source package.
+ Rpmlint quite on binary package.
+ Rpmlint quite on debuginfo package.
+ Local install/update of package works fine.
+ Build on Mock works fine.

*** APPROVED ***





Comment 6 Paul Wouters 2010-10-15 14:04:35 UTC
Package Change Request
======================
Package Name: perl-Net-DNS
New Branches: el-5 el-6
Owners: mmaslano pwouters 
InitialCC: mmaslano

perl-Net-DNS is needed as dependancy for perl-Net-DNSSEC which is already in el-5/el-6 but cannot be build now due to this missing dependancy.

It does not matter to me who will be the owner. It can be the original package owner, or I can take it on, or we can co-maintain....

Comment 7 Jason Tibbitts 2010-10-15 14:11:47 UTC
Erm, no, perl-Net-DNS is as far as I can tell a part of base RHEL.  We can't branch it for EPEL.

Comment 8 Paul Wouters 2010-10-24 03:25:05 UTC
ok. i guess perl-Net-DNS-SEC should be removed from el-5 then. I'll look into it.

Comment 9 Petr Pisar 2012-08-10 12:43:33 UTC
Package Change Request
======================
Package Name: perl-Net-DNS
Branches: f16 f17 f18
Owners: 
InitialCC: perl-sig

Please add perl-sig user with watch* permissions only to all Fedora branches.

Comment 10 Gwyn Ciesla 2012-08-10 13:01:11 UTC
Done.


Note You need to log in before you can comment on or make changes to this bug.