Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226249 - Merge Review: perl-Date-Calc
Summary: Merge Review: perl-Date-Calc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:34 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-12 10:34:58 UTC
panemade: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 20:34:38 UTC
Fedora Merge Review: perl-Date-Calc

http://cvs.fedora.redhat.com/viewcvs/devel/perl-Date-Calc/
Initial Owner: rnorwood@redhat.com

Comment 1 Parag AN(पराग) 2007-10-22 10:23:32 UTC
1)perl as BR is not needed. mock build without it worked successfully.
   remove redundant dependency on perl >= 1:5.6.1
2)you may like to use disttag
3)rpmlint only complained ->
perl-Date-Calc.src: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 3)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.
==>Use "sed -i -e 's|\t|  |g' perl-Date-Calc.spec"

===> I think you can add following to SPEC
chmod 644  examples/*.{pl,cgi} tools/*.pl
after adding that rpmlint mesasges got reduced to 
perl-Date-Calc.i386: W: file-not-utf8 /usr/share/doc/perl-Date-Calc-5.4/EXAMPLES.txt
The character encoding of this file is not UTF-8.  Consider converting it
in the specfile for example using iconv(1).

perl-Date-Calc.i386: W: spurious-executable-perm
/usr/share/doc/perl-Date-Calc-5.4/tools/compile.sh
The file is installed with executable permissions, but was identified as one
that probably should not be executable.  Verify if the executable bits are
desired, and remove if not.

perl-Date-Calc.i386: W: wrong-file-end-of-line-encoding
/usr/share/doc/perl-Date-Calc-5.4/tools/compile.bat
This file has wrong end-of-line encoding, usually caused by creation or
modification on a non-Unix system. It could prevent it from being displayed
correctly in some circumstances.

perl-Date-Calc.i386: W: file-not-utf8 /usr/share/doc/perl-Date-Calc-5.4/CREDITS.txt
The character encoding of this file is not UTF-8.  Consider converting it
in the specfile for example using iconv(1).

perl-Date-Calc.i386: E: useless-explicit-provides perl(Date::Calc)
This package provides 2 times the same capacity. It should only provide it
once.



Comment 2 Robin Norwood 2007-10-25 03:28:13 UTC
Included all of the above fixes - for compile.bat, I just used dos2unix on it. 
We  could also just 'rm' it...I don't know which is preferred.

New version is perl-Date-Calc-5.4-3.fc9

Comment 3 Parag AN(पराग) 2007-10-25 03:47:12 UTC
you missed 
BR: dos2unix

Comment 4 Patrice Dumas 2007-10-25 07:43:04 UTC
You can also use

sed -i -e 's/\r//'

to avoid the dependency on dos2unix.

Comment 5 Robin Norwood 2007-10-25 20:48:58 UTC
The BR: is there - can you double check please?

[rnorwood@solitude tmp]$ wget
http://koji.fedoraproject.org/packages/perl-Date-Calc/5.4/3.fc9/src/perl-Date-Calc-5.4-3.fc9.src.rpm
[rnorwood@solitude tmp]$ rpm -qp --requires perl-Date-Calc-5.4-3.fc9.src.rpm 
perl(Bit::Vector) >= 6.4
perl(ExtUtils::MakeMaker)  
dos2unix  
rpmlib(CompressedFileNames) <= 3.0.4-1
[rnorwood@solitude tmp]$ md5sum perl-Date-Calc-5.4-3.fc9.src.rpm 
b7493810b674ddb1c0de3385ced25a4f  perl-Date-Calc-5.4-3.fc9.src.rpm


Comment 6 Parag AN(पराग) 2007-10-26 05:42:20 UTC
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
7ae34972694127e8f1c9a2af1c24585b  Date-Calc-5.4.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ make test outputs
All tests successful.
Files=48, Tests=2770,  3 wallclock secs ( 2.20 cusr +  0.35 csys =  2.55 CPU)
+ Package perl-Date-Calc-5.4-3.fc8 ->
 Provides: Calc.so perl(Date::Calc::Object) = 5.4 perl(Date::Calendar) = 5.4
perl(Date::Calendar::Profiles) = 5.4 perl(Date::Calendar::Year) = 5.4
Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) perl(:MODULE_COMPAT_5.8.8)
perl(Bit::Vector) perl(Bit::Vector) >= 6.4 perl(Carp::Clan)
perl(Date::Calc::Object) perl(Date::Calendar::Year) perl(DynaLoader)
perl(Exporter) perl(strict) perl(vars) rtld(GNU_HASH)

APPROVED.


Comment 7 Parag AN(पराग) 2007-11-11 07:04:24 UTC
Can we CLOSE this review if package is already built and in rawhide?


Note You need to log in before you can comment on or make changes to this bug.