Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226180 - Merge Review: mysql
Summary: Merge Review: mysql
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On: 223713
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:14 UTC by Nobody's working on this, feel free to take it
Modified: 2014-04-02 17:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-02 17:45:44 UTC
oget.fedora: fedora-review?


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 20:14:30 UTC
Fedora Merge Review: mysql

http://cvs.fedora.redhat.com/viewcvs/devel/mysql/
Initial Owner: tgl@redhat.com

Comment 1 Orcan Ogetbil 2009-01-17 23:01:40 UTC
The full review arrived!

* Summary and especially the description are bizarre. Can you update them. You can find these on the manpage:
    Xinerama - API for Xinerama extension to X11 Protocol   

    Xinerama is a simple library designed to interface the Xinerama Extension for 
    retrieving information about physical output devices which may be combined 
    into a single logical X screen.

* rpmlint says
   libXinerama.src:18: W: unversioned-explicit-obsoletes XFree86-libs
   libXinerama.src:18: W: unversioned-explicit-obsoletes xorg-x11-libs
   libXinerama.src:32: W: unversioned-explicit-obsoletes XFree86-devel
   libXinerama.src:32: W: unversioned-explicit-obsoletes xorg-x11-devel
   libXinerama.x86_64: E: zero-length /usr/share/doc/libXinerama-1.0.3/AUTHORS
   libXinerama.x86_64: E: zero-length /usr/share/doc/libXinerama-1.0.3/README
   libXinerama.x86_64: W: obsolete-not-provided XFree86-libs
   libXinerama.x86_64: W: obsolete-not-provided xorg-x11-libs
   libXinerama-devel.x86_64: W: obsolete-not-provided XFree86-devel
   libXinerama-devel.x86_64: W: obsolete-not-provided xorg-x11-devel
The zero-length files are obviously not needed so they should be removed. The obsoletes look very problematic. Can you fix those (or alternatively explain them in the SPEC file as comments)?

* BR: libXau-devel is not needed. Afaict it is not used.

* BRs: libX11-devel pkgconfig and xorg-x11-proto-devel are not needed. They will be picked up by libXext-devel.

* Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig' (for directory ownership and usability). This applies to the devel package.

! Try to make use of the %{name} macro (e.g. files sections).

* Parallel make must be supported whenever possible. If it is not supported, this should be noted in the SPEC file as a comment.


Added Adam and Matthias to CC since they are the last two known maintainers. Sorry if this was not desired.

Comment 2 Orcan Ogetbil 2009-01-17 23:03:48 UTC
Shoot! Wrong bug. Sorry for the mess.

I'll review this next.

Comment 3 Orcan Ogetbil 2009-01-17 23:24:56 UTC
I can't find the koji entry for the new version.. I guess it is still being worked on. 

fitzsim, can you provide a SRPM when you're done?

Comment 4 Matthew Miller 2014-04-02 17:45:44 UTC
No longer in Fedora.


Note You need to log in before you can comment on or make changes to this bug.