Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226053 - Merge Review: libusb
Summary: Merge Review: libusb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks: FE-ACCEPT
TreeView+ depends on / blocked
 
Reported: 2007-01-31 19:28 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-29 04:52:25 UTC
rc040203: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 19:28:24 UTC
Fedora Merge Review: libusb

http://cvs.fedora.redhat.com/viewcvs/devel/libusb/
Initial Owner: jnovy@redhat.com

Comment 1 Ralf Corsepius 2007-02-05 06:41:41 UTC
* Doesn't build on FC6 due to some issues related to it's docs (docbook):
...
jade -t sgml -d ./website.dsl\#html ./manual.sgml
jade:./website.dsl:2:95:W: cannot generate system identifier for public text
"-//Norman Walsh//DOCUMENT DocBook HTML Stylesheet//EN"
...

* The spec contains all kind of odd auto*-related hacks.
AFAICS, all these are superfluous if 
"make DESTDIR="${RPM_OPT_FLAGS}" install"
was used.

* Package contains static libs.

Comment 2 Jindrich Novy 2007-02-06 09:50:06 UTC
Seems to be caused by a missing openjade BuildRequires.

Comment 3 Jindrich Novy 2007-02-06 10:23:24 UTC
Builds fine for me after adding the BR in the freshly created rawhide chroot
installed with minimal dependencies on i386.

Comment 4 Ralf Corsepius 2007-02-06 10:44:27 UTC
You are still using this auto* hacks - why?

You should be able to condense all this into:

%build
%configure --disable-static
make

%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=${RPM_BUILD_ROOT} install
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la


Comment 5 Jindrich Novy 2007-02-06 11:25:36 UTC
Yeah, I can remove the autofoo stuff, but I'm not sure about removing the libusb
static library. libusb is low-level enough that someone would really wish to
link against libusb statically, so how about introducing libusb-static package
shipping static stuff? Simply removing the static libs completely now as you
propose is no a good way to follow.

Comment 6 Ralf Corsepius 2007-02-06 15:15:07 UTC
(In reply to comment #5)
> I'm not sure about removing the libusb
> static library. 
I can't imagine any reason for needing the static libs, so I am highly in favor
of removing them. Nevertheless, introducing *-static would be a compromize, to
force those deps on static libs to become apparent and give those packages more
time to move to shared libs rsp. to provide a precendence for a case in which
static libs are required.

Comment 7 Jindrich Novy 2007-02-08 13:07:49 UTC
Please check the latest libusb (7.fc7). I added the static subpackage there.

Comment 8 Ralf Corsepius 2007-02-16 14:18:26 UTC
Sorry, on fc6, building still fails with the jade/docbook error reported in #1.

Did you try to build this package for fc6?

Comment 9 Jindrich Novy 2007-02-20 11:30:56 UTC
Yes, I tried to build the rawhide libusb on FC6 and it failed in the
documentation generation phase because of some jade inconsistency. The question
is whether this is related to merge review as we focus on F7 here.

Comment 10 Ralf Corsepius 2007-02-20 11:39:12 UTC
Sorry, I don't have a rawhide system installed. 
=> Somebody else will have to take over the review.



Comment 11 Jindrich Novy 2007-02-20 11:48:16 UTC
Ralf, thanks for your comments and review. Maybe mock will help you here to do a
rawhide build if you are still interested.

Comment 12 Ralf Corsepius 2007-02-20 15:15:16 UTC
Now, things are getting interesting ...

ATM, *-7.src.rpm doesn't fail in an fc6-mock, but it fails in a normal 
user environment ... <confused/>


Comment 13 Jindrich Novy 2007-02-20 15:21:53 UTC
/me suspects some jade config clashes caused by updates

Comment 14 Ralf Corsepius 2007-02-21 16:54:46 UTC
(In reply to comment #13)
> /me suspects some jade config clashes caused by updates
Probably, I found my sgml/xml catalogs were broken ;)

Package builds fine under FC6 and FC7 now, unfortunately between all these
"proposals", I've lost oversight on what the current way is to approve a package.

APPROVED

Comment 15 Jindrich Novy 2007-02-21 17:19:57 UTC
Thanks!

Comment 16 Ralf Corsepius 2007-11-29 04:52:25 UTC
Housekeeping, seems as if this PR should have been closed long time ago, but got
lost during the transition to flagged reviews.



Note You need to log in before you can comment on or make changes to this bug.