Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225822 - Merge Review: gnome-media
Summary: Merge Review: gnome-media
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 18:51 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-11 01:25:48 UTC
dakingun: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 18:51:52 UTC
Fedora Merge Review: gnome-media

http://cvs.fedora.redhat.com/viewcvs/devel/gnome-media/
Initial Owner: alexl@redhat.com

Comment 1 Deji Akingunola 2007-02-07 22:39:18 UTC
A couple of issues for gnome-media;

NEEDSWORK:
 * rpmlint (on the binary package, the -devel subpackage, and the srpm) produces
a number of warnings/errors. Most of it can possibly be ignored, but I think the
rpath issue need to be fixed
>>
 [deji@agape reviews]$ rpmlint gnome-media-2.17.90-1.fc7.x86_64.rpm
E: gnome-media tag-not-utf8 %changelog
E: gnome-media obsolete-not-provided gnome
E: gnome-media binary-or-shlib-defines-rpath
/usr/lib64/libglade/2.0/libgnome-media-profiles.so ['/usr/lib64']
E: gnome-media binary-or-shlib-defines-rpath
/usr/bin/gnome-audio-profiles-properties ['/usr/lib64']
E: gnome-media binary-or-shlib-defines-rpath /usr/bin/gnome-cd ['/usr/lib64']
E: gnome-media binary-or-shlib-defines-rpath /usr/libexec/cddb-track-editor
['/usr/lib64']
W: gnome-media non-conffile-in-etc /etc/gconf/schemas/CDDB-Slave2.schemas
W: gnome-media non-conffile-in-etc /etc/gconf/schemas/gnome-audio-profiles.schemas
W: gnome-media non-conffile-in-etc /etc/gconf/schemas/gnome-volume-control.schemas
W: gnome-media non-conffile-in-etc /etc/gconf/schemas/gnome-cd.schemas
[deji@agape reviews]$ rpmlint gnome-media-devel-2.17.90-1.fc7.x86_64.rpm
E: gnome-media-devel tag-not-utf8 %changelog
W: gnome-media-devel no-documentation
[deji@agape reviews]$ rpmlint gnome-media-2.17.90-1.fc7.src.rpm
E: gnome-media tag-not-utf8 %changelog
E: gnome-media non-utf8-spec-file gnome-media.spec
W: gnome-media unversioned-explicit-obsoletes gnome
W: gnome-media macro-in-%changelog _datadir
W: gnome-media mixed-use-of-spaces-and-tabs (spaces: line 12, tab: line 22)

 * scrollkeeper-update is not being properly called in the post and postun
sections according to
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets?action=show&redirect=ScriptletSnippets#head-a4ea5e1946bc113d19d24b4f5bfb543c579e5fc8
 * "--add-category X-Redhat-Base" option to desktop-file-install is no longer
necesary

Not so importantly, the "disable-schemas-install" option can be pass to the
configure script instead of setting and unsetting
GCONF_DISABLE_MAKEFILE_SCHEMA_INSTAL env.

Comment 2 Deji Akingunola 2007-02-07 22:42:23 UTC
The packaging guildelines on removing rpath is here;
http://fedoraproject.org/wiki/Packaging/Guidelines?highlight=%28rpath%29#head-7cea8c7aa96400a4687e843156354476434ff883

Comment 3 Bastien Nocera 2007-02-08 11:27:41 UTC
(In reply to comment #1)
> A couple of issues for gnome-media;
> 
> NEEDSWORK:
>  * rpmlint (on the binary package, the -devel subpackage, and the srpm) produces
> a number of warnings/errors. Most of it can possibly be ignored, but I think the
> rpath issue need to be fixed
> >>
>  [deji@agape reviews]$ rpmlint gnome-media-2.17.90-1.fc7.x86_64.rpm
> E: gnome-media tag-not-utf8 %changelog

Fixed

> E: gnome-media obsolete-not-provided gnome
> E: gnome-media binary-or-shlib-defines-rpath
> /usr/lib64/libglade/2.0/libgnome-media-profiles.so ['/usr/lib64']
> E: gnome-media binary-or-shlib-defines-rpath
> /usr/bin/gnome-audio-profiles-properties ['/usr/lib64']
> E: gnome-media binary-or-shlib-defines-rpath /usr/bin/gnome-cd ['/usr/lib64']
> E: gnome-media binary-or-shlib-defines-rpath /usr/libexec/cddb-track-editor
> ['/usr/lib64']
> W: gnome-media non-conffile-in-etc /etc/gconf/schemas/CDDB-Slave2.schemas
> W: gnome-media non-conffile-in-etc /etc/gconf/schemas/gnome-audio-profiles.schemas
> W: gnome-media non-conffile-in-etc /etc/gconf/schemas/gnome-volume-control.schemas
> W: gnome-media non-conffile-in-etc /etc/gconf/schemas/gnome-cd.schemas

Fixed.

> [deji@agape reviews]$ rpmlint gnome-media-devel-2.17.90-1.fc7.x86_64.rpm
> E: gnome-media-devel tag-not-utf8 %changelog
> W: gnome-media-devel no-documentation
> [deji@agape reviews]$ rpmlint gnome-media-2.17.90-1.fc7.src.rpm
> E: gnome-media tag-not-utf8 %changelog
> E: gnome-media non-utf8-spec-file gnome-media.spec

Fixed.

> W: gnome-media unversioned-explicit-obsoletes gnome
> W: gnome-media macro-in-%changelog _datadir

Fixed.

> W: gnome-media mixed-use-of-spaces-and-tabs (spaces: line 12, tab: line 22)

Fixed.

>  * scrollkeeper-update is not being properly called in the post and postun
> sections according to
>
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets?action=show&redirect=ScriptletSnippets#head-a4ea5e1946bc113d19d24b4f5bfb543c579e5fc8

Fixed

>  * "--add-category X-Redhat-Base" option to desktop-file-install is no longer
> necesary

That's commented.

> Not so importantly, the "disable-schemas-install" option can be pass to the
> configure script instead of setting and unsetting
> GCONF_DISABLE_MAKEFILE_SCHEMA_INSTAL env.

Fixed.


All of this is fixed in gnome-media-2.17.90-3.fc7, I'll need to work on the
rpath issue now.

Comment 4 Bastien Nocera 2007-02-08 12:25:19 UTC
And fixed the rpath issue in gnome-media-2.17.90-4.fc7. Let me know if anything
else needs work.

Comment 5 Bastien Nocera 2007-02-08 13:20:14 UTC
And will really be fixed in gnome-media-2.17.90-5.fc7, I forgot to *actually*
apply the configure changes...

Comment 6 Deji Akingunola 2007-02-08 13:20:59 UTC
I was looking at the cvs commit mail, and it seems you forgot to actually commit
the change ;). I'm waiting for anonymous cvs to sync up so I can properly test it. 

Comment 7 Deji Akingunola 2007-02-08 14:13:37 UTC
The rpath issue is still present;
[deji@agape reviews]$ rpmlint gnome-media-2.17.90-5.fc7.x86_64.rpm
E: gnome-media tag-not-utf8 %changelog
E: gnome-media obsolete-not-provided gnome
E: gnome-media binary-or-shlib-defines-rpath
/usr/lib64/libglade/2.0/libgnome-media-profiles.so ['/usr/lib64']
E: gnome-media binary-or-shlib-defines-rpath
/usr/bin/gnome-audio-profiles-properties ['/usr/lib64']
E: gnome-media binary-or-shlib-defines-rpath /usr/bin/gnome-cd ['/usr/lib64']
E: gnome-media binary-or-shlib-defines-rpath /usr/libexec/cddb-track-editor
['/usr/lib64']
W: gnome-media conffile-without-noreplace-flag
/etc/gconf/schemas/CDDB-Slave2.schemas
W: gnome-media conffile-without-noreplace-flag
/etc/gconf/schemas/gnome-audio-profiles.schemas
W: gnome-media conffile-without-noreplace-flag /etc/gconf/schemas/gnome-cd.schemas
W: gnome-media conffile-without-noreplace-flag
/etc/gconf/schemas/gnome-volume-control.schemas

The problem is caused by the package using it's local copy of libtool, as can be
seen from the build log (excerpt below). I believe this can be fixed by having a
buildrequire on libtool and forcing the build to use the system libtool ("make
LIBTOOL=/usr/bin/libtool ...")
(  /bin/sh ../libtool --mode=install /usr/bin/install -c
'cddb-slave2-properties'
'/var/tmp/gnome-media-2.17.90-5.fc7-root-mockbuild/usr/bin/cddb-slave2-properties'
/usr/bin/install -c cddb-slave2-properties
/var/tmp/gnome-media-2.17.90-5.fc7-root-mockbuild/usr/bin/cddb-slave2-properties
test -z "/usr/libexec" || mkdir -p --
"/var/tmp/gnome-media-2.17.90-5.fc7-root-mockbuild/usr/libexec"
  /bin/sh ../libtool --mode=install /usr/bin/install -c 'CDDBSlave2'
'/var/tmp/gnome-media-2.17.90-5.fc7-root-mockbuild/usr/libexec/CDDBSlave2'
/usr/bin/install -c CDDBSlave2
/var/tmp/gnome-media-2.17.90-5.fc7-root-mockbuild/usr/libexec/CDDBSlave2
  /bin/sh ../libtool --mode=install /usr/bin/install -c 'cddb-track-editor'
'/var/tmp/gnome-media-2.17.90-5.fc7-root-mockbuild/usr/libexec/cddb-track-editor'
)

Probably an upstream issue, I noticed the install section of the build doesn't
respect the configure option to disable scrollkeeper; it still variously
attempts to update the scrollkeeper.

Comment 8 Bastien Nocera 2007-02-08 14:27:35 UTC
I checked with --disable-rpath on i386, and it didn't happen. I'll try and work
on that upstream instead for now.

Comment 9 Deji Akingunola 2007-02-08 14:37:13 UTC
That explains it, I was testing on x86_64

Comment 10 Bastien Nocera 2007-02-08 17:39:03 UTC
I've made some local changes, but the gist of it is that we need to force a new
libtool in the tarball to get rid of the rpath warnings.

As for the scrollkeeper bits, we'll need to remove them ourselves from the
omf.make as well, as gnome-media doesn't use gnome-doc-utils, which provides and
respects the --disable-scrollkeeper argument:
http://bugzilla.gnome.org/show_bug.cgi?id=405821

Comment 11 Matthias Clasen 2007-02-08 20:13:28 UTC
The simple-minded approach to the scrollkeeper problem is to just 
rm -rf $RPM_BUILD_ROOT/var/scrollkeeper in %build.

Comment 12 Bastien Nocera 2007-02-08 23:20:29 UTC
(In reply to comment #11)
> The simple-minded approach to the scrollkeeper problem is to just 
> rm -rf $RPM_BUILD_ROOT/var/scrollkeeper in %build.

Actually, it tries to update the database in /var/scrollkeeper, not
$RPM_BUILD_ROOT/var/scrollkeeper...

It's all built in gnome-media-2.17.90-6.fc7

Comment 13 Deji Akingunola 2007-02-09 14:52:26 UTC
GOOD:
 * Build Ok in mock (x86_64)
 * License (GPL) and rpm Group tag OK
 * Naming meets the packaging guildlines
 * Spec file clean and legible
 * Handles locales correctly
 * Build dependencies properly listed
 * Source file matches upstream's
094a92f01a3581de7b3567f85320df7b  gnome-media-2.17.90.tar.bz2
 * Own its files and directories correctly

rpmlint warnings/error: This can mostly be ignored
[deji@agape reviews]$ rpmlint gnome-media-2.17.90-6.fc7.x86_64.rpm
E: gnome-media obsolete-not-provided gnome
W: gnome-media conffile-without-noreplace-flag
/etc/gconf/schemas/CDDB-Slave2.schemas
W: gnome-media conffile-without-noreplace-flag
/etc/gconf/schemas/gnome-audio-profiles.schemas
W: gnome-media conffile-without-noreplace-flag /etc/gconf/schemas/gnome-cd.schemas
W: gnome-media conffile-without-noreplace-flag
/etc/gconf/schemas/gnome-volume-control.schemas
[deji@agape reviews]$ rpmlint gnome-media-2.17.90-6.fc7.src.rpm
W: gnome-media unversioned-explicit-obsoletes gnome
[deji@agape reviews]$ rpmlint gnome-media-devel-2.17.90-6.fc7.x86_64.rpm
W: gnome-media-devel no-documentation

However I wonder if it's not just OK to drop that Obsoletes on gnome, it seems
superfluous of gnome-media to Obsolete gnome as it cannot also provide it
(gnome). I believe you can fix that, so

APPROVED.




APPROVED.

Comment 14 Matthias Clasen 2007-08-11 01:25:48 UTC
This review is done.


Note You need to log in before you can comment on or make changes to this bug.