Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225816 - Merge Review: gnome-doc-utils
Summary: Merge Review: gnome-doc-utils
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 18:50 UTC by Nobody's working on this, feel free to take it
Modified: 2008-06-30 06:45 UTC (History)
4 users (show)

Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 06:45:06 UTC
petersen: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 18:50:59 UTC
Fedora Merge Review: gnome-doc-utils

http://cvs.fedora.redhat.com/viewcvs/devel/gnome-doc-utils/
Initial Owner: mbarnes@redhat.com

Comment 1 Jens Petersen 2007-03-26 07:47:26 UTC
Output from rpmlint:

srpm
W: gnome-doc-utils buildprereq-use libxml2-devel >= 2.6.12
W: gnome-doc-utils buildprereq-use libxslt-devel >= 1.1.8

rpm
E: gnome-doc-utils explicit-lib-dependency libxml2-python
W: gnome-doc-utils devel-file-in-non-devel-package /usr/share/pkgconfig/xml2po.pc
W: gnome-doc-utils devel-file-in-non-devel-package
/usr/share/pkgconfig/gnome-doc-utils.pc



Comment 2 Matthias Clasen 2007-06-17 04:26:29 UTC
I've fixed up Requires and BuildRequires a bit.


E: gnome-doc-utils explicit-lib-dependency libxml2-python

This sounds like rpmlint is smoking something...


W: gnome-doc-utils devel-file-in-non-devel-package /usr/share/pkgconfig/xml2po.pc
W: gnome-doc-utils devel-file-in-non-devel-package
/usr/share/pkgconfig/gnome-doc-utils.pc

These are just rpmlint not knowing that gnome-doc-utils is
a devel package.

Comment 3 Jens Petersen 2007-06-19 08:25:41 UTC
Thanks.  I agree those can certainly be waived.

About the license field, would it be better to list it as GPL/LGPL?
I am not sure what is the best way to designate that it is a mixture
of GPL and LGPL scripts?

Anyway COPYING, COPYING.GPL and COPYING.LGPL must be included in %doc.

Comment 4 Jens Petersen 2007-10-02 08:20:55 UTC
% rpmlint gnome-doc-utils-0.12.0-1.fc8.noarch.rpm
gnome-doc-utils.noarch: E: explicit-lib-dependency libxml2-python
gnome-doc-utils.noarch: W: invalid-license GFDL+

According to http://fedoraproject.org/wiki/Licensing
the short name is GFDL.

Comment 5 Jens Petersen 2007-10-08 05:44:46 UTC
Here is my review:

Good:
+ meets packaging and naming guidelines
+ project is GPL
+ spec file is clearly written
+ source is pristine
5934c08d12407d8233416343cd73df24  gnome-doc-utils-0.12.0.tar.bz2
+ lists buildrequires
+ file ownership looks good (except yelp problem mentioned also below)

Needs attention:
- rpmlint output
gnome-doc-utils.src: W: invalid-license GFDL+
gnome-doc-utils.noarch: E: explicit-lib-dependency libxml2-python
gnome-doc-utils.noarch: W: invalid-license GFDL+
gnome-doc-utils-stylesheets.noarch: W: no-documentation
gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
/usr/share/pkgconfig/gnome-doc-utils.pc
gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
/usr/share/pkgconfig/xml2po.pc
- /usr/share/gnome/help ownership:
Dunno if it would make sense have a different package (like filesystem) to
own this dir rather than yelp if it is problematic to require yelp?

If GFDL is mentioned as an additional license for the .xml files then I think
LGPL+ should also be mentioned for the .xsl files.
The GFDL license is not included though, so since it is embedded I am
not sure if it is strictly necessary to mention GFDL in the License field.

Otherwise the package looks good to me.

Comment 6 Jens Petersen 2007-11-13 06:40:17 UTC
ping

Comment 7 Jens Petersen 2008-02-18 07:33:37 UTC
Dropping review for lack of response.

Comment 8 Parag AN(पराग) 2008-02-18 11:07:23 UTC
Can we drop this package from fedora if nobody willing to maintain this or mark
this as orphaned?

Comment 9 Huzaifa S. Sidhpurwala 2008-02-18 12:17:29 UTC
I want to maintain this package, If there are no objections?

Comment 10 Matthew Barnes 2008-02-18 16:35:34 UTC
(In reply to comment #5)
> gnome-doc-utils.src: W: invalid-license GFDL+

Changed to GFDL.

> gnome-doc-utils-stylesheets.noarch: W: no-documentation

Fixed some time ago.

> gnome-doc-utils.noarch: E: explicit-lib-dependency libxml2-python
> gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
> /usr/share/pkgconfig/gnome-doc-utils.pc
> gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
> /usr/share/pkgconfig/xml2po.pc

Invalid.  See comment #2.

> - /usr/share/gnome/help ownership:
> Dunno if it would make sense have a different package (like filesystem) to
> own this dir rather than yelp if it is problematic to require yelp?

Please reopen bug #205799 if this is still an issue.

> If GFDL is mentioned as an additional license for the .xml files then I think
> LGPL+ should also be mentioned for the .xsl files.

Added LGPLv2+.

License changes applied to gnome-doc-utils-0.12.1-2.fc9.

Comment 11 Debarshi Ray 2008-05-25 19:37:44 UTC
Is this review still "(stalled)" ?

Comment 12 Jens Petersen 2008-06-30 06:34:12 UTC
(In reply to comment #11)
> Is this review still "(stalled)" ?

Yes - feel free to continue it.

Comment 13 Jens Petersen 2008-06-30 06:45:06 UTC
Thanks for the update in comment 10.

Based on this I think the package is ok now.

APPROVED



Note You need to log in before you can comment on or make changes to this bug.