Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225768 - Merge Review: foomatic
Summary: Merge Review: foomatic
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Skala
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
: 225227 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 18:39 UTC by Nobody's working on this, feel free to take it
Modified: 2014-11-09 22:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-22 10:05:02 UTC
jskala: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 18:39:58 UTC
Fedora Merge Review: foomatic

http://cvs.fedora.redhat.com/viewcvs/devel/foomatic/
Initial Owner: twaugh@redhat.com

Comment 1 Michael Schwendt 2007-05-25 09:50:30 UTC
*** Bug 225227 has been marked as a duplicate of this bug. ***

Comment 2 Jiri Skala 2010-01-21 15:35:49 UTC
There are rpmlint errors to fix:
- prereq-use fileutils initscripts
- hardcoded-library-path

Comment 3 Tim Waugh 2010-01-21 16:39:22 UTC
(In reply to comment #2)
> - prereq-use fileutils initscripts

Fixed in foomatic-4.0.3-10.fc13.

> - hardcoded-library-path    

Yes, this is intentional, as the comments indicate:

export LIB_CUPS=/usr/lib/cups               # /usr/lib NOT libdir
export CUPS_BACKENDS=/usr/lib/cups/backend  # /usr/lib NOT libdir
export CUPS_FILTERS=/usr/lib/cups/filter    # /usr/lib NOT libdir

CUPS filters and backends are located in /usr/lib/cups/filters and /usr/lib/cups/backends even on x86_64 platforms.

Comment 4 Jiri Skala 2010-01-22 10:05:02 UTC
rpmlint complains    fixed, explained
license              ok
url                  ok
sources              ok
nvr nameing          ok
%clean               ok
buildroot            ok
build flags          ok
install rm -rf...    ok
files                ok
mockbuild            ok


Note You need to log in before you can comment on or make changes to this bug.