Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225761 - Merge Review: fonts-chinese
Summary: Merge Review: fonts-chinese
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 18:38 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-30 23:37:00 UTC
petersen: fedora-review+


Attachments (Terms of Use)
Some Changes to SPEC file (deleted)
2007-03-01 06:22 UTC, Parag AN(पराग)
no flags Details | Diff

Description Nobody's working on this, feel free to take it 2007-01-31 18:38:52 UTC
Fedora Merge Review: fonts-chinese

http://cvs.fedora.redhat.com/viewcvs/devel/fonts-chinese/
Initial Owner: cchance@redhat.com

Comment 1 Parag AN(पराग) 2007-03-01 05:53:44 UTC
Mock build is successful. 
But build.log showed 
warning: File listed twice: /usr/share/fonts/chinese/TrueType
warning: File listed twice: /usr/share/fonts/chinese/TrueType/fonts.cache-1
warning: File listed twice: /usr/share/fonts/chinese/TrueType/fonts.dir
warning: File listed twice: /usr/share/fonts/chinese/TrueType/fonts.scale
warning: File listed twice: /usr/share/fonts/chinese/misc
warning: File listed twice: /usr/share/fonts/chinese/misc/fonts.cache-1
warning: File listed twice: /usr/share/fonts/chinese/misc/fonts.dir
warning: File listed twice: /usr/share/fonts/chinese/misc/fonts.scale

Also rpmlint on SRPM and RPM reported
W: fonts-chinese invalid-license Arphic Public License (GPL-like)
The value of the License tag was not recognized.  Known values are:
"Academic Free License", "Adaptive Public License", "Apache License", "Apache
Software License", "Apple Public Source License", "Artistic", "Attribution
Assurance License", "BSD", "Computer Associates Trusted Open Source License",
"CDDL", "CPL", "CUA Office Public License", "EU DataGrid Software License",
"Eclipse Public License", "Educational Community License", "Eiffel Forum
License", "Entessa Public License", "Fair License", "Frameworx License",
"GPL", "LGPL", "Historical Permission Notice and Disclaimer", "IBM Public
License", "Intel Open Source License", "Jabber Open Source License", "Lucent
Public License", "MIT", "CVW License", "Motosoto License", "MPL", "NASA Open
Source Agreement", "Naumen Public License", "Nethack General Public License",
"Nokia Open Source License", "OCLC Research Public License", "Open Group Test
Suite License", "Open Software License", "PHP License", "Python license",
"Python Software Foundation License", "QPL", "RealNetworks Public Source
License", "Reciprocal Public License", "Ricoh Source Code Public License",
"Sleepycat License", "Sun Industry Standards Source License", "Sun Public
License", "Sybase Open Watcom Public License", "University of Illinois/NCSA
Open Source License", "Vovida Software License", "W3C License", "wxWindows
Library License", "X.Net License", "Zope Public License", "zlib/libpng
License", "Creative Commons Attribution", "Creative Commons Attribution-
NoDerivs", "Creative Commons Attribution-NonCommercial-NoDerivs", "Creative
Commons Attribution-NonCommercial", "Creative Commons Attribution-
NonCommercial-ShareAlike", "Creative Commons Attribution-ShareAlike", "Design
Public License", "GFDL", "LaTeX Project Public License", "OpenContent
License", "Open Publication License", "Public Domain", "Ruby License", "SIL
Open Font License", "Charityware", "Commercial", "Distributable", "Freeware",
"Non-distributable", "Proprietary", "Shareware".
If the license is close to an existing one, you can use '<license> style'.

W: fonts-chinese no-url-tag
The URL tag is missing.

W: fonts-chinese strange-permission fonts-chinese-modified.spec 0755
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

E: fonts-chinese invalid-spec-name fonts-chinese-modified.spec
Your spec filename must end with '.spec'. If it's not the case, rename your
file and rebuild your package.

W: fonts-chinese unversioned-explicit-obsoletes ttfonts-zh_CN
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-chinese unversioned-explicit-obsoletes ttfonts-zh_TW
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-chinese unversioned-explicit-obsoletes ttf-moe_sung
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-chinese unversioned-explicit-obsoletes ttf-moe_kai
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-chinese unversioned-explicit-obsoletes ttf-arphic_bming
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-chinese unversioned-explicit-obsoletes ttf-arphic_bkai
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-chinese unversioned-explicit-obsoletes taipeifonts
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-chinese mixed-use-of-spaces-and-tabs (spaces: line 4, tab: line 1)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.



W: fonts-chinese no-url-tag
The URL tag is missing.

E: fonts-chinese obsolete-not-provided ttfonts-zh_CN
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-chinese obsolete-not-provided ttfonts-zh_TW
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-chinese obsolete-not-provided ttf-moe_sung
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-chinese obsolete-not-provided ttf-moe_kai
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-chinese obsolete-not-provided ttf-arphic_bming
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-chinese obsolete-not-provided ttf-arphic_bkai
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-chinese obsolete-not-provided taipeifonts
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

W: fonts-chinese non-conffile-in-etc /etc/ghostscript/cidfmap.zh_CN
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-chinese non-conffile-in-etc /etc/ghostscript/FAPIcidfmap.zh_CN
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-chinese non-conffile-in-etc /etc/ghostscript/FAPIcidfmap.zh_TW
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-chinese non-conffile-in-etc /etc/ghostscript/CIDFnmap.zh_TW
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-chinese non-conffile-in-etc /etc/ghostscript/cidfmap.zh_TW
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-chinese non-conffile-in-etc /etc/ghostscript/CIDFnmap.zh_CN
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-chinese dangerous-command-in-%post ln


For Obsoletes warning you may like to see 
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-3cfc1ea19d28975faad9d56f70a6ae55661d3c3d

Also for fonts package you need to add fonts scriptlet. Check out
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-4863fc4c93cec14292719d8901d83f5d90c3e477


Comment 2 Parag AN(पराग) 2007-03-01 05:58:25 UTC
Oops original SPEC is not having following problems as i commented last. My mistake
W: fonts-chinese strange-permission fonts-chinese-modified.spec 0755
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

E: fonts-chinese invalid-spec-name fonts-chinese-modified.spec
Your spec filename must end with '.spec'. If it's not the case, rename your
file and rebuild your package.



Comment 3 Parag AN(पराग) 2007-03-01 06:16:17 UTC
Also i miss to paste following rpmlint warnings
W: fonts-chinese summary-ended-with-dot Chinese TrueType Font -- Simplified and
Traditional Chinese Ming and Kai Face.
Summary ends with a dot.

E: fonts-chinese description-line-too-long Chinese TTF Fonts donated by Arphic
company, with additional Hong Kong characters by Hong Kong font project and
bitmap by F
Your description lines must not exceed 79 characters. If a line is exceeding
this number, cut it to fit in two lines.

W: fonts-chinese wrong-file-end-of-line-encoding
/usr/share/doc/fonts-chinese-3.03/doc/arphicpl.txt
This file has wrong end-of-line encoding, usually caused by creation or
modification on a non-Unix system. It could prevent it from being displayed
correctly in some circumstances.



Comment 4 Parag AN(पराग) 2007-03-01 06:22:23 UTC
Created attachment 148992 [details]
Some Changes to SPEC file

Here is what you SHOULD do
1)Use attached SPEC
2)Add versions to Obsoletes
3)Add provides for each packages listed in Obsoletes
4)Add fonts scriptlets

Comment 5 Parag AN(पराग) 2007-03-14 05:43:53 UTC
In case you have %config and %config(noreplace) in your SPEC then You may like
to update the SPEC by removing that.
Check http://fedoraproject.org/wiki/Packaging/Minutes20070313
and http://fedoraproject.org/wiki/PackagingDrafts/UsrConfigs

Comment 6 Parag AN(पराग) 2007-04-10 10:17:52 UTC
No response from maintainer yet ;)

Comment 7 Caius Chance 2007-04-11 00:32:21 UTC
Hi Parag, are you talking about me? - Caius

Comment 8 Jens Petersen 2007-08-03 00:59:43 UTC
Yes, since no update here.

Also fc-cache needs to be passed the font directory.
Please see
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-4863fc4c93cec14292719d8901d83f5d90c3e477

Comment 9 Jens Petersen 2007-08-03 01:22:41 UTC
umask's in %post and %postun can go too.

Comment 10 Jens Petersen 2007-08-06 08:25:45 UTC
(In reply to comment #9)
> umask's in %post and %postun can go too.

Well maybe not - they also appear in other packages actually.
So need some consensus on that.

Comment 11 Caius Chance 2007-09-25 23:38:20 UTC
Since the taipeifont is being independent, there would be no sources in this
package.

fonts-chinese might be converted into a meta-package with just dependencies on
rpms of all available Chinese fonts.

Jens, could you kindly discuss the above process with me?

Comment 12 Jens Petersen 2007-09-26 08:10:11 UTC
Can you prepare a draft spec file and I will give feedback.
Look at the new fonts-korean.spec as an example.

Comment 14 Jens Petersen 2007-09-28 06:40:22 UTC
Basically looks fine to me.

A few comments:

- better to use: %defattr(-,root,root,-)
- I'd put taipeifonts after cjkunifonts in the requires.
- please describe in the changelog that the change is that
  taipei fonts was moved to a separate package taipeifonts.


Comment 15 Jens Petersen 2007-09-28 06:47:21 UTC
Potentially we could also drop taipeifonts from fonts-chinese if
it is not that important for most Chinese users?

Comment 17 Caius Chance 2007-09-28 07:00:05 UTC
Personally I would be more preferred to have a replacement of taipeifonts before
dropping that.

Comment 18 Jens Petersen 2007-09-28 07:26:41 UTC
Looks fine to me.

Please go ahead and commit this to cvs and I will approve it. :)

We can close this when it has been built.

Comment 19 Jens Petersen 2007-09-30 23:37:00 UTC
Thanks for fonts-chinese-3.03-12.fc8.

Package is APPROVED.


Note You need to log in before you can comment on or make changes to this bug.