Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225675 - Merge Review: db4
Summary: Merge Review: db4
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks: F9MergeReviewTarget
TreeView+ depends on / blocked
 
Reported: 2007-01-31 17:55 UTC by Nobody's working on this, feel free to take it
Modified: 2009-01-14 16:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-14 16:35:33 UTC
gwync: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 17:55:22 UTC
Fedora Merge Review: db4

http://cvs.fedora.redhat.com/viewcvs/devel/db4/
Initial Owner: jnovy@redhat.com

Comment 1 Gwyn Ciesla 2008-01-24 18:08:46 UTC
rpmlint on srpm:

Lots of unversioned obsoletes, but since they're for db3, db2, etc, so I think
that's ok.

db4.src: W: mixed-use-of-spaces-and-tabs (spaces: line 133, tab: line 4)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.

Cosmetic, but easy to fix.

db4.src: W: invalid-license BSD-style

Change to BSD.

No documentation warnings for -cxx, -tcl packages.

db4-java.i386: W: devel-file-in-non-devel-package /usr/lib/libdb_java-4.6.a
db4-tcl.i386: W: devel-file-in-non-devel-package /usr/lib/libdb_tcl-4.6.a

db4-utils.i386: E: non-standard-executable-perm /usr/bin/db_deadlock 0555
And many other in /usr/bin.

These need to be corrected or explained in spec.

There are .la files in some packages.  These are not allowed, and should either
be removed or be justified in the spec.  Same goes for static libs.  If they are
needed by a dependent package, state this in the spec.

Other than the above, no other blockers.

Comment 2 Gwyn Ciesla 2008-05-16 15:04:17 UTC
Any updates?

Comment 3 Gwyn Ciesla 2008-09-09 15:22:18 UTC
Eval of current srpm:

rpmlint on srpm:

Unversioned obsoletes, as above, plus:

db4.src: W: mixed-use-of-spaces-and-tabs (spaces: line 140, tab: line 167)
The specfile mixes use of spaces and tabs for indentation, which is a cosmetic
annoyance.  Use either spaces or tabs for indentation, not both.

db4.src: W: patch-not-applied Patch22: db-4.5.20-jni-include-dir.patch
A patch is included in your package but was not applied. Refer to the patches
documentation to see what's wrong.

rpmlint on rpms:

No docs for -cxx, -tcl and -static.  Still the non-standard exec perm.

.la and static libs are good now.

So, improvement, not there yet, but easy to fix or explain.

Comment 4 Jindrich Novy 2008-09-11 09:47:26 UTC
(In reply to comment #3)
> Eval of current srpm:
> 
> rpmlint on srpm:
> 
> Unversioned obsoletes, as above, plus:

This should be fine since the obsoletes are there because of very ancient BDB versions (mostly all RHL ones) and they will never appear again.

> 
> db4.src: W: mixed-use-of-spaces-and-tabs (spaces: line 140, tab: line 167)
> The specfile mixes use of spaces and tabs for indentation, which is a cosmetic
> annoyance.  Use either spaces or tabs for indentation, not both.

This should be fixed now.

> 
> db4.src: W: patch-not-applied Patch22: db-4.5.20-jni-include-dir.patch
> A patch is included in your package but was not applied. Refer to the patches
> documentation to see what's wrong.

D'oh, seems like I forgot to apply the patch actually after rediffing. It is now fixed as well.

> rpmlint on rpms:
> 
> No docs for -cxx, -tcl and -static.  Still the non-standard exec perm.

The problem is that there is no documentation for -static, since it is actually the same as -devel but statically linked. The -cxx, -tcl is shipped without docs since there is shipped only runtime bits and I stuffed all the docs, which are actually of any use by developers into -devel subpackage.

Thanks for the review.

Comment 5 Gwyn Ciesla 2008-09-12 12:12:28 UTC
Ok, sounds good, can you place the above comments on the obsoletes and docs in the spec, for posterity?

Comment 6 Gwyn Ciesla 2008-12-04 19:33:29 UTC
Ping?

Comment 7 Jindrich Novy 2008-12-05 13:34:49 UTC
Jon, I'm unsure what comments to put to which place. db4 contains unversioned obsoletes in subpackages as well. So pasting comments before the Obsoletes in each subpackage seems a bit messy to me.

Comment 8 Gwyn Ciesla 2008-12-05 13:50:04 UTC
Agreed, I'd put them before the Obsoletes for the utils subpackage, and explain that it applies to all the rest as well.  Comments for the -static (lack of)docs can go in the %files static right before %doc.

Comment 9 Robert Scheck 2009-01-13 22:20:14 UTC
Jindrich, Jon - ping?

Comment 10 Jindrich Novy 2009-01-14 07:37:31 UTC
Forgot to post an update here. Added this comment to unversioned obsoletes in spec preamble:

# unversioned obsoletes are OK here as these BDB versions never occur again
Obsoletes: db1, db2, db3

Comment 11 Gwyn Ciesla 2009-01-14 16:35:33 UTC
Looks great.  Full review of the current version looks good.

APPROVED.


Note You need to log in before you can comment on or make changes to this bug.