Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225623 - Merge Review: bootparamd
Summary: Merge Review: bootparamd
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ruben Kerkhof
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 17:46 UTC by Nobody's working on this, feel free to take it
Modified: 2008-01-23 19:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-23 19:34:30 UTC
ruben: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 17:46:39 UTC
Fedora Merge Review: bootparamd

http://cvs.fedora.redhat.com/viewcvs/devel/bootparamd/
Initial Owner: stransky@redhat.com

Comment 1 Ruben Kerkhof 2007-03-18 12:30:39 UTC
Needs work:
* Package does not follow Fedora's package naming guildlines
  (wiki: PackageNamingGuidelines)
* BuildRoot should be %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  (wiki: PackagingGuidelines#BuildRoot)
* Encoding should be UTF-8
* The package should contain the text of the license
  (wiki: Packaging/ReviewGuidelines)
* Scriptlets: missing "service" in %preun (wiki: ScriptletSnippets)
* Scriptlets: missing "service" in %postun (wiki: ScriptletSnippets)

Rpmlint is not silent:

Source RPM:
W: bootparamd summary-ended-with-dot A server process which provides boot information to diskless 
clients.
E: bootparamd tag-not-utf8 %changelog
W: bootparamd no-url-tag
W: bootparamd strange-permission bootparamd.init 0775
E: bootparamd non-utf8-spec-file bootparamd.spec
W: bootparamd prereq-use /sbin/chkconfig /etc/init.d
E: bootparamd use-of-RPM_SOURCE_DIR
W: bootparamd mixed-use-of-spaces-and-tabs (spaces: line 49, tab: line 1)

rpmlint of bootparamd:
W: bootparamd summary-ended-with-dot A server process which provides boot information to diskless 
clients.
E: bootparamd tag-not-utf8 %changelog
W: bootparamd no-url-tag
W: bootparamd conffile-without-noreplace-flag /etc/rc.d/init.d/bootparamd
E: bootparamd executable-marked-as-config-file /etc/rc.d/init.d/bootparamd


Comment 2 Ruben Kerkhof 2007-06-17 06:35:09 UTC
Ping?

Comment 3 Martin Stransky 2007-09-10 10:16:37 UTC
That should be fixed with the current package maintainer who is Ondrej Dvoracek. 

Comment 4 Ondrej Dvoracek 2007-10-08 10:15:39 UTC
Hi,

> * Package does not follow Fedora's package naming guildlines
>   (wiki: PackageNamingGuidelines)
renamed source tarball so it matches upstream tarball and added correct upstream
source tarball url

> * BuildRoot should be
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
>   (wiki: PackagingGuidelines#BuildRoot)
corrected the BuildRoot

> * Encoding should be UTF-8
removed invalid character from spec file

> * The package should contain the text of the license
>   (wiki: Packaging/ReviewGuidelines)
the upstream package does not contain the text of the license so I can't add the
license text to the tarball

> * Scriptlets: missing "service" in %preun (wiki: ScriptletSnippets)
> * Scriptlets: missing "service" in %postun (wiki: ScriptletSnippets)
corrected scriptlets according to the ScriptletsSnippets

RPMLINT:

Source RPM:
> W: bootparamd summary-ended-with-dot A server process which provides boot
information to diskless clients.
removed dot

> E: bootparamd tag-not-utf8 %changelog
removed invalid character from changelog

> W: bootparamd no-url-tag
there is no bootparamd page

> W: bootparamd strange-permission bootparamd.init 0775
don't know what to do with that, many other services has the same problem

> E: bootparamd non-utf8-spec-file bootparamd.spec
removed invalid character from spec file

> W: bootparamd prereq-use /sbin/chkconfig /etc/init.d
removed prereq use and added correct requires according to the ScriptletsSnippets

> E: bootparamd use-of-RPM_SOURCE_DIR
removed usage of RPM_SOURCE_DIR

> W: bootparamd mixed-use-of-spaces-and-tabs (spaces: line 49, tab: line 1)
using spaces

rpmlint of bootparamd:
> W: bootparamd summary-ended-with-dot A server process which provides boot
information to diskless clients.
removed dot

> E: bootparamd tag-not-utf8 %changelog
removed invalid character from changelog

> W: bootparamd no-url-tag
there is no bootparamd page

> W: bootparamd conffile-without-noreplace-flag /etc/rc.d/init.d/bootparamd
> E: bootparamd executable-marked-as-config-file /etc/rc.d/init.d/bootparamd
/etc/rc.d/init.d/bootparamd is not a config file

Cheers Ondrej

Comment 5 Ruben Kerkhof 2007-11-26 15:53:38 UTC
Hi Ondrej,

> W: bootparamd strange-permission bootparamd.init 0775
don't know what to do with that, many other services has the same problem

This is a warning because the file has 0775 permissions in CVS, chmodding 0664 will fix that.

>> W: bootparamd no-url-tag
> there is no bootparamd page

Agreed.

All the other issues are resolved.

Thanks,

Ruben

Comment 6 Ondrej Dvoracek 2007-11-26 16:15:23 UTC
Hi,
I know where the problem is, but I can't change permissions in CVS. We've looked
at it with my colleague and it is common that permissions of init files are set
like these. So we've filed a bug on rpmlint upstream and you can see the result
on http://rpmlint.zarb.org/cgi-bin/trac.cgi/ticket/110. That is everything I can
do with that.
Cheers Ondrej

Comment 7 Ruben Kerkhof 2007-11-26 20:05:45 UTC
Maybe you could do a CVS Admin Request 
(http://fedoraproject.org/wiki/PackageMaintainers/CVSAdminProcedure) to have the permissions changed 
in the repository?

Comment 8 Ruben Kerkhof 2008-01-21 22:21:10 UTC
Hi cvs admins,

Would it be possible to change the permissions on bootparamd.init to 0664 in the repo?

Comment 9 Kevin Fenzi 2008-01-22 23:46:24 UTC
It might be possible, but I don't have permissions to do so. 
Will see if it can be done.

Comment 10 Jason Tibbitts 2008-01-23 00:00:45 UTC
Well, there's /cvs/pkgs/rpms/bootparamd/devel on cvs-int, which does show
bootparamd.init,v as being mode 555.  I have no idea what would happen if that
were changed to 444.

Comment 11 Toshio Ernie Kuratomi 2008-01-23 19:17:55 UTC
Okay.  /cvs/pkgs/rpms/bootparamd/devel has had its mode changed to 0444.  Let us
know if that causes any problems (it should do exactly what you want.)

Comment 12 Ruben Kerkhof 2008-01-23 19:34:30 UTC
Thanks, it's fixed!

I don't see any further issues so this package is approved.


Note You need to log in before you can comment on or make changes to this bug.