Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225593 - Unable to mount a dm device
Summary: Unable to mount a dm device
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 16:02 UTC by Sanjay Rao
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-01 15:41:25 UTC


Attachments (Terms of Use)

Description Sanjay Rao 2007-01-31 16:02:12 UTC
Description of problem:

Unable to mount a multipath device (dm-0). This message is seen when an attempt
is made to mount the device.

[root@perf6 ~]# mount /dev/dm-0 /ora1
mount: /dev/dm-0 already mounted or /ora1 busy

This is the output of the df command which shows that the device is not mounted.

[root@perf6 ~]# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      66815628   4605972  58760824   8% /
/dev/sda1               101105     12346     83538  13% /boot
tmpfs                  4066208         0   4066208   0% /dev/shm
bigpapi:/vol/engineering/redhat
                     2996410816 2935548416  60862400  98% /bigpapi
qafiler:/vol/vol1    1411220568     52048 1411168520   1% /qafiler


This is the output of the /proc/mounts

[root@perf6 ~]# more /proc/mounts
rootfs / rootfs rw 0 0
/dev/root / ext3 rw,data=ordered 0 0
/dev /dev tmpfs rw 0 0
/proc /proc proc rw 0 0
/sys /sys sysfs rw 0 0
/proc/bus/usb /proc/bus/usb usbfs rw 0 0
devpts /dev/pts devpts rw 0 0
/dev/sda1 /boot ext3 rw,data=ordered 0 0
tmpfs /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
bigpapi:/vol/engineering/redhat /bigpapi nfs rw,vers=3,rsize=65536,wsize=65536,h
ard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=bigpapi 0 0
qafiler:/vol/vol1 /qafiler nfs rw,vers=3,rsize=8192,wsize=8192,hard,proto=tcp,ti
meo=600,retrans=2,sec=sys,addr=qafiler 0 0
/etc/auto.misc /misc autofs rw,fd=6,pgrp=4458,timeout=300,minproto=5,maxproto=5,
indirect 0 0
-hosts /net autofs rw,fd=11,pgrp=4458,timeout=300,minproto=5,maxproto=5,indirect
 0 0

The output of fuser showing that the device is not being used by any other
processes.

[root@perf6 ~]# fuser /dev/dm-0
[root@perf6 ~]# 



Version-Release number of selected component (if applicable):


How reproducible:

It is reproducible on this system. It occurs even after a reboot.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Zeuthen 2007-01-31 18:54:57 UTC
This should probably be against util-linux, not dasher. Reassigning.

Comment 2 Peter Jones 2007-01-31 18:58:48 UTC
Can you show the results of "dmsetup table" ?

Comment 3 Sanjay Rao 2007-01-31 19:02:08 UTC
[root@perf6 multipath]# dmsetup table
mpath2: 0 142239510 multipath 0 0 1 1 round-robin 0 2 1 8:32 1000 8:96 1000 
mpath1: 0 142264000 multipath 0 0 1 1 round-robin 0 1 1 8:16 100 
VolGroup01-LogVol01: 0 4063232 linear 253:9 137953664
VolGroup01-LogVol00: 0 137953280 linear 253:9 384
mpath1p3: 0 16002 linear 253:7 63
VolGroup00-LogVol01: 0 4063232 linear 8:2 137953664
mpath5: 0 71119755 multipath 0 0 1 1 round-robin 0 2 1 8:80 1000 8:144 1000 
mpath1p2: 0 142030665 linear 253:7 224910
VolGroup00-LogVol00: 0 137953280 linear 8:2 384
mpath4: 0 142239510 multipath 0 0 1 1 round-robin 0 2 1 8:64 1000 8:128 1000 
mpath1p1: 0 208845 linear 253:7 16065
mpath3: 0 142239510 multipath 0 0 1 1 round-robin 0 2 1 8:48 1000 8:112 1000 
mpath2p1: 0 142239510 linear 253:0 0

This is the mapping of the mpath devices to dm devices
[root@perf6 mpath]# ls -l
total 0
lrwxrwxrwx 1 root root 7 Jan 31 10:44 mpath1 -> ../dm-7
lrwxrwxrwx 1 root root 7 Jan 31 10:44 mpath1p1 -> ../dm-8
lrwxrwxrwx 1 root root 7 Jan 31 10:44 mpath1p2 -> ../dm-9
lrwxrwxrwx 1 root root 8 Jan 31 10:44 mpath1p3 -> ../dm-10
lrwxrwxrwx 1 root root 7 Jan 31 10:44 mpath2 -> ../dm-0
lrwxrwxrwx 1 root root 7 Jan 31 10:44 mpath3 -> ../dm-2
lrwxrwxrwx 1 root root 7 Jan 31 10:44 mpath4 -> ../dm-3
lrwxrwxrwx 1 root root 7 Jan 31 10:44 mpath5 -> ../dm-4







Comment 4 Peter Jones 2007-01-31 21:23:33 UTC
Ok, and "dmsetup ls", please?

Comment 5 Sanjay Rao 2007-01-31 21:26:51 UTC
[root@perf6 dev]# dmsetup ls
mpath2  (253, 0)
mpath1  (253, 7)
VolGroup01-LogVol01     (253, 12)
VolGroup01-LogVol00     (253, 11)
mpath1p3        (253, 10)
VolGroup00-LogVol01     (253, 6)
mpath5  (253, 4)
mpath1p2        (253, 9)
VolGroup00-LogVol00     (253, 5)
mpath4  (253, 3)
mpath1p1        (253, 8)
mpath3  (253, 2)
mpath2p1        (253, 1)


Comment 6 Peter Jones 2007-02-01 15:41:25 UTC
Ok, I don't think anything is going wrong here -- you can't mount /dev/mpath2
directly because it has a partition on it, which is mpath2p1.  Do "parted
/dev/mpath2 p" to see the partition table for more info on that.


Note You need to log in before you can comment on or make changes to this bug.