Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225591 - Windows installation on Xen requires workaround
Summary: Windows installation on Xen requires workaround
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager
Version: 5.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Daniel Berrange
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 15:38 UTC by Mike Jang
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-31 16:28:14 UTC


Attachments (Terms of Use)

Description Mike Jang 2007-01-31 15:38:10 UTC
Description of problem:
Installation of Windows XP in full virtualization mode requires workaround

Version-Release number of selected component (if applicable):
xen-3.0.3-8.el5

How reproducible:
Use virt-manager to install RHEL 5, with the workaround described in
https://virt.108.redhat.com/articles/2007/01/15/xen-guest-installation.pdf

Steps to Reproduce:
1. Per Red Hat document shown
2.
3.
  
Actual results:
Does not even work, after the first XP installation reboot.

Expected results:
Installation should proceed after the first XP installation routine reboot.

Any workaround, as described in the Red Hat document, should not be required -
or the workaround should be incorporated into virt-manager

Additional info:
from qemu-dm log file
qemu: the number of cpus is 1
shared page at pfn:1f3ff, mfn: 2cddf
buffered io page at pfn:1f3fd, mfn: 2cde1
xs_read(): vncpasswd get error. /vm/e17ac834-d261-adf1-e5a5-79d0c7e31cd5/vncpasswd.
Could not initialize SDL - exiting

(I've also tried with the vnc console enabled, with a similar result)

Comment 1 Daniel Berrange 2007-01-31 16:28:14 UTC
The workaround documented there rather overcomplicates the issue. All that is
needed is to map in the CDROM device on the 2nd boot. This is already being
tracked in bug 223444

*** This bug has been marked as a duplicate of 223444 ***


Note You need to log in before you can comment on or make changes to this bug.