Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225564 - System with degraded RAID1 (ESB2) does not boot.
Summary: System with degraded RAID1 (ESB2) does not boot.
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Fedora
Classification: Fedora
Component: dmraid
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: LVM and device-mapper development team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 11:42 UTC by Winfrid Tschiedel
Modified: 2009-08-25 12:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 18:14:01 UTC


Attachments (Terms of Use)

Description Winfrid Tschiedel 2007-01-31 11:42:31 UTC
Description of problem:

On a Fujitsu Siemens Celsius R640 I installed a fedora core 6 (x86_64) 
on a SATA RAID ( Mirror ). The system has an ESB2. The RAID1 was configured
with Intel Matrix Storage Manager option ROM v5.6.1002ESB2. 
The system was upgrade to the actual patch-level ( Jan. 30, 2007 ).
To simulate an error on the RAID configuration, I removed one disc.
A reboot causes now a kernel panic.

Version-Release number of selected component (if applicable):


How reproducible:
Always, reproduced also on rhel 5 beta2


Steps to Reproduce:
1. Have System with ESB2 or ICH8R and configured RAID1 (isw)
2. Install fedora core 6 or rhel 5, update the system
3. remove 1 disc from the mirror - reboot the system
  
Actual results:

The decompresses the actual kernel ( 2.6.19-1.2896.fc6 ) and boots the kernel.
Red Hat nash version 5.1.19.0.2 starts :

After this I get the following errors :
device-mapper: table: 253:0: mirror: Device lookup failure
device-mapper: reload ioctl failed: No such device or address
Unable to access resume device (LABEL=SWAP-isw_bcegte)
mount could not find device '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc
setuproot: error mounting /sys
switchroot: mount failed
Kernel panic - not syncing

Expected results:

System boots also with one disc 
and if a second disc is added the mirror is syncronized


Additional info:
Same problem occurs on FSC tx200-s3 (ESB2),
but in this case LSI firmware is used and ddf1 raid

Comment 1 Petr Rockai 2007-03-14 08:35:16 UTC
This is hardware RAID issue, not a dm-raid one, as far as i understand you. 
Trying to assign to kernel, but this may as well be a bios problem.

What i don't understand is
device-mapper: table: 253:0: mirror: Device lookup failure
you are running lvm mirror on top of the HW raid1?

If this is in fact a LVM mirror issue and unrelated to the RAID hardware, 
please flip the bug to lvm2 component (it may turn out to be an initrd issue 
as well, though).

Comment 2 Petr Rockai 2007-03-14 09:06:16 UTC
Sorry, now i see that you are using fake raid, not actual hardware raid. This 
may indeed be dmraid issue then, or initrd one.

Comment 3 Bryn M. Reeves 2007-04-11 18:14:01 UTC

*** This bug has been marked as a duplicate of 224219 ***


Note You need to log in before you can comment on or make changes to this bug.