Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225555 - smp kernel panics on boot with quad-core HP xw6400
Summary: smp kernel panics on boot with quad-core HP xw6400
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 11:04 UTC by Atte Kojo
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version: kernel-smp-2.6.9-46.EL
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-01 13:54:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
Kernel boot log (deleted)
2007-01-31 11:04 UTC, Atte Kojo
no flags Details

Description Atte Kojo 2007-01-31 11:04:42 UTC
Description of problem:
When booting smp kernel on HP xw6400 with with two dual-core Xeon 5160's the 
kernel panics (using noapic didn't help). The uniprocessor kernel boots ok.

Version-Release number of selected component (if applicable):
2.6.9-42.0.8.ELsmp, 2.6.9-42.0.3 Didn't work either

How reproducible:
Boot computer with smp kernel

Steps to Reproduce:
1. 
2. 
3.
  
Actual results:
Kernel panics

Expected results:
Kernel boots normally

Additional info:
Kernel boot log attached

Comment 1 Atte Kojo 2007-01-31 11:04:42 UTC
Created attachment 147010 [details]
Kernel boot log

Comment 2 Jarod Wilson 2007-02-06 01:06:35 UTC
Dual-core (and Quad-core) support has been one of the things worked on for U5. Can you give one of the 
pre-U5 test kernels a try?

http://people.redhat.com/~jbaron/rhel4/RPMS.kernel/

Recent kernels work rather well internally on an xw6400 here in the office.

Comment 3 Atte Kojo 2007-02-07 06:21:51 UTC
Tried kernel-smp-2.6.9-46.EL.x86_64.rpm and it boots normally. Probably will
also work fine.

Strange thing, though, is that that upon boot of the new kernel kudzu found a
"new" device: 'Intel Corporation 631xESB/632xESB IDE Controller'.

Comment 4 Jason Baron 2007-04-13 20:30:50 UTC
hmm, does this message come up on every boot, or just the first time?

Comment 5 Atte Kojo 2007-08-01 07:02:25 UTC
The new device message hasn't show up in subsequent boots. Also, all kernels 
after 2.6.9-46 have worked fine.

As far as I am concerned this can be closed as fixed.


Note You need to log in before you can comment on or make changes to this bug.