Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225553 - Errore controllo transazione: (yum: transaction control error)
Summary: Errore controllo transazione: (yum: transaction control error)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 10:34 UTC by aldo furlan
Modified: 2014-01-21 22:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-16 18:16:08 UTC


Attachments (Terms of Use)
Yumex log. (deleted)
2007-01-31 10:34 UTC, aldo furlan
no flags Details
History of proposed solutions (deleted)
2007-02-01 09:16 UTC, aldo furlan
no flags Details

Description aldo furlan 2007-01-31 10:34:34 UTC
Description of problem:
Fedora 6 OS from updated Fedora 4.
Arch. I86_64.
Yum (yumex)  updating to e2fsprogs-1.39-7.fc6 reports conflict error with file
from package e2fsprogs-1.37-4.
See attachment.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 aldo furlan 2007-01-31 10:34:34 UTC
Created attachment 147008 [details]
Yumex log.

Comment 2 Thomas Woerner 2007-01-31 13:03:00 UTC
You do have two different e2fsprogs versions installed: e2fsprogs-1.38-0.FC4.1,
e2fsprogs-1.37-4

This is the core of the problem. Please try to update e2fsprogs with yum 'yum
update "e2fsprogs*"'.

This is a yum or yumex problem, threfore assigning to yum.

Comment 3 aldo furlan 2007-01-31 13:59:26 UTC
I tryied your suggestion but I got the same result as before.
I did yum update e2fsprogs-devel; it went fine for e2fsprogs-devel,
e2fsprogs-libs-devel.
But trying: yum update e2fsprogs give me the "conflicts" as before.

Tanks.
            Aldo Furlan

Comment 4 Seth Vidal 2007-01-31 21:39:36 UTC
please run this script:
http://linux.duke.edu/~skvidal/useful-scripts/dupes-cli.py

then run a yum update.

see if the problem gets fixed.

Comment 5 aldo furlan 2007-02-01 09:16:34 UTC
Created attachment 147078 [details]
History of proposed solutions

Comment 6 aldo furlan 2007-02-01 09:24:38 UTC
I beg your pardon. I am new to this list. I commented out the attachment but 
it was not send.
I did as Seth instructed me. The script worked fine and the e2fsprogs-1.37-4 
has gone.
But the problem persists.
See the attachment, which contains the history.





Comment 7 aldo furlan 2007-02-16 18:13:17 UTC
The bug is solved.
I had to manually delete

e2fsprogs-1.38-0.FC4.1

That package was not deleted when I upgraded the system from Fedora 4 to Fedora 6.
          Aldo Furlan



Note You need to log in before you can comment on or make changes to this bug.