Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225549 - bootrecord always written to MBR, when dmraid is installed
Summary: bootrecord always written to MBR, when dmraid is installed
Keywords:
Status: CLOSED DUPLICATE of bug 225548
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 10:07 UTC by Winfrid Tschiedel
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-04 15:33:43 UTC


Attachments (Terms of Use)

Description Winfrid Tschiedel 2007-01-31 10:07:16 UTC
Description of problem:

Even if during installation write bootrecord to boot-section is selected,
an existing MBR is overwritten.

Version-Release number of selected component (if applicable):
fedora core6 installation dvd


How reproducible:
Always, same error was also seen on rhel 5.


Steps to Reproduce:
1. Install fedora core 6 on a system with SATA Raid.
2. Install a second fedora core 6 on the same system and select
   write bootrecord to bootsection.
3. reboot
  
Actual results:
 
   The second fedora installation will be bootet.


Expected results:

   Boot of the first fedora Installation.
    To get access to 2. installation, you should
    only insert 3 lines in /boot/grub/menu.lst of the 1. installation

title Fedora (2. Installation)
    root (hd0,x)
    chainloader +1 


Additional info:
    similar problems occur on openSUSE 10.2

Comment 1 Johan Kok 2007-02-04 15:33:43 UTC
Thank you for reporting this issue. It appears your issue was stored three times in our bug tracker. I'm 
closing this one as a duplicate of bug #225548

*** This bug has been marked as a duplicate of 225548 ***


Note You need to log in before you can comment on or make changes to this bug.