Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225540 - Incorrect mynetworks setting cause postfix reject all the connections from clients
Summary: Incorrect mynetworks setting cause postfix reject all the connections from cl...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postfix
Version: 4.4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 08:43 UTC by Zhenyong(Jerry) Jiang
Modified: 2013-07-29 00:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-08 09:11:36 UTC


Attachments (Terms of Use)

Description Zhenyong(Jerry) Jiang 2007-01-31 08:43:34 UTC
Description of problem:
Incorrect mynetworks setting cause postfix reject all the connections from clients
The config like this:

......
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated,
permit_auth_destination, reject
smtpd_sasl_auth_enable = yes
smtpd_delay_reject = yes
smtpd_client_restrictions = permit_sasl_authenticated
broken_sasl_auth_clients = yes
smtpd_sasl_security_options = noanonymous
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mynetworks = 10.217.64.0/16 192.168.100.0/24 127.0.0.0/8
# In the above line, I put a intended error network id of  10.217.64.0/16 
......


Version-Release number of selected component (if applicable):
postfix-2.2.10, 
The problem do not effect the earlier version

How reproducible:

Steps to Reproduce:
1. Add the above lines to the /etc/postfix/main.cf
2. restart the service 
3.  Telnet smtp port of mail server ip.  The connection will be disconnected by
mailserver.
 
Actual results:
  The connection will be disconnected by mailserver.

[root@intellpc1 mnt]# telnet 127.0.0.1 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.

Connection closed by foreign host.
[root@intellpc1 mnt]# 


Expected results:


Additional info:

Comment 1 Phil Knirsch 2008-08-26 14:07:13 UTC
What would be the correct behavior with incorrect settings? I guess and error during startup?

Thanks,

Read ya, Phil

Comment 2 Miroslav Lichvar 2010-03-08 09:11:36 UTC
We are sorry for not addressing this issue in RHEL-4. As postfix is not
scheduled for an update in RHEL-4.9, I'm closing this bug as WONTFIX. If you
are still experiencing this issue with RHEL-5, please reopen it against RHEL-5.


Note You need to log in before you can comment on or make changes to this bug.