Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225539 - PV framebuffer doesn't work in shadow translate mode
Summary: PV framebuffer doesn't work in shadow translate mode
Keywords:
Status: CLOSED DUPLICATE of bug 216169
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Markus Armbruster
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 08:02 UTC by Markus Armbruster
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-31 08:33:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Markus Armbruster 2007-01-31 08:02:11 UTC
Description of problem:
The PV framebuffer doesn't work on shadow translate mode, because it doesn't
translate gpfn to mfn.  Upstream doesn't need that translation, because the
hypervisor accepts gpfns in 3.0.4.

How reproducible:
always

Steps to Reproduce:
1. Make sure pvfb is enabled (it is by default)
2. Start the pv domain, e.g. with xm create DOMNAME
  
Actual results:
pvfb backend daemon dies during startup.

Expected results:
pvfb backend process runs.

Additional info:

var/log/xen/xend-debug.log:
/local/domain/0/backend/vfb/2/0 on fire (Invalid argument)
/local/domain/0/backend/vkbd/2/0 on fire (Invalid argument)

Comment 1 Markus Armbruster 2007-01-31 08:33:41 UTC

*** This bug has been marked as a duplicate of 216169 ***


Note You need to log in before you can comment on or make changes to this bug.