Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225531 - ia64 PTRACE_GETREGS touches pt_all_user_regs words that should be left alone
Summary: ia64 PTRACE_GETREGS touches pt_all_user_regs words that should be left alone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: ia64
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Roland McGrath
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 05:40 UTC by Roland McGrath
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:23:36 UTC


Attachments (Terms of Use)
test case (deleted)
2007-01-31 05:40 UTC, Roland McGrath
no flags Details
patch to fix the issue (deleted)
2007-05-08 08:55 UTC, Luming Yu
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Roland McGrath 2007-01-31 05:40:54 UTC
Older kernels' PTRACE_GETREGS request ignored certain words and did not fill in
the user memory there at all.  The utrace patch broke this.

The output of the attached test case should be:

Unmodified register by PTRACE_GETREGS request
 gr0 --- gr0
 ar1 --- ar15
 ar21 --- ar31
 ar34 --- ar35
 ar38 --- ar39
 ar42 --- ar63
 ar68 --- ar127
 fr0 --- fr1

Comment 1 Roland McGrath 2007-01-31 05:40:55 UTC
Created attachment 147002 [details]
test case

Comment 2 RHEL Product and Program Management 2007-01-31 06:25:09 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 3 Luming Yu 2007-04-02 03:21:52 UTC
Is it fixed in upstream?

Comment 4 Luming Yu 2007-04-10 09:32:17 UTC
Tested with latest upstream kernel with utrace patch linux-2.6-utrace.patch.
There isn't such problem. 


Comment 6 Luming Yu 2007-05-08 08:55:48 UTC
Created attachment 154319 [details]
patch to fix the issue

Does this patch fix your problem. 
I tested it with the latest redhat el5 kernel on ia64 box. It works as
expected.

Comment 7 Roland McGrath 2007-05-08 09:00:18 UTC
I filed this bug on myself for tracking purposes.
I already plan a utrace update for 5.1 that will pull in all the upstream fixes,
including this one.  No need to separately backport it.

Comment 9 RHEL Product and Program Management 2007-06-20 12:31:53 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 10 Don Zickus 2007-07-19 19:54:13 UTC
in kernel-2.6.18-30.el5

Comment 12 Mike Gahagan 2007-08-28 18:10:28 UTC
Confirmed proper operation of the test case with the -43 kernel. 


Comment 14 errata-xmlrpc 2007-11-07 19:23:36 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.