Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225461 - libgconf should not require gtk
Summary: libgconf should not require gtk
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: GConf2
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-01-30 18:41 UTC by Stepan Kasal
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 19:38:32 UTC


Attachments (Terms of Use)

Description Stepan Kasal 2007-01-30 18:41:48 UTC
GConf2 rpm currently requires the whole GTK.

This is unfortunate, because glib + libgconf should be enough for command-line
utilities which use gconf, but not X.  (For example, frysk.rpm is full of such
utilities; the GUI for Frysk has been searated to frysk-gnome.rpm.)

The cause is /usr/libexec/gconf-sanity-check-2 which is linked against gtk.
Automatic dependencies then bring gtk to reuirements.

Could this be resolved?  Prehaps by moving the GUI utility to a separate rpm?

Comment 1 Matthias Clasen 2007-02-02 05:28:24 UTC
I think I agree, we should move the sanity-check to a subpackage.
When we do so, we need to update gnome-session to require the subpackage.

Comment 2 Matthias Clasen 2007-02-05 19:38:32 UTC
There is a GConf2-gtk subpackage now.


Note You need to log in before you can comment on or make changes to this bug.