Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225437 - TBfef41469 versionlock.py:45:exclude_hook:PluginYumExit: Unable to read version lock configuration: [Errno 5] OSError: [Errno 2] No such file or directory: '/etc/yum/pluginconf.d/versionlock.list'
Summary: TBfef41469 versionlock.py:45:exclude_hook:PluginYumExit: Unable to read versi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: 5
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 221880 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-30 16:52 UTC by muscimol
Modified: 2014-01-21 22:57 UTC (History)
2 users (show)

Fixed In Version: 1.0.x
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 11:57:04 UTC


Attachments (Terms of Use)

Description muscimol 2007-01-30 16:52:43 UTC
Description of problem:

Component: Software Updater
Summary: TBfef41469 versionlock.py:45:exclude_hook:PluginYumExit: Unable to read
version lock configuration: [Errno 5] OSError: [Errno 2] No such file or
directory: '/etc/yum/pluginconf.d/versionlock.list'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 389, in ?
    main()
  File "/usr/sbin/pup", line 385, in main
    pup.run()
  File "/usr/sbin/pup", line 357, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 161, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 154, in reposSetup
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 299, in doSackSetup
    self.plugins.run('exclude')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/versionlock.py", line 45, in exclude_hook
    raise PluginYumExit('Unable to read version lock configuration: %s' % e)
PluginYumExit: Unable to read version lock configuration: [Errno 5] OSError:
[Errno 2] No such file or directory: '/etc/yum/pluginconf.d/versionlock.list'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0xb35ae9cc>
e: [Errno 5] OSError: [Errno 2] No such file or directory:
'/etc/yum/pluginconf.d/versionlock.list'
locklist: []
location: /etc/yum/pluginconf.d/versionlock.list
Version-Release number of selected component (if applicable):


How reproducible:

everytime I start yum oor any software updater
Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Johan Kok 2007-02-05 10:06:33 UTC
*** Bug 221880 has been marked as a duplicate of this bug. ***

Comment 2 Tim Lauridsen 2007-02-07 07:29:37 UTC
The problem is if you install the version lock plugin your have to add some
packages to lock in '/etc/yum/pluginconf.d/versionlock.list' or you have to
disable the plugin  (enabled=0) in '/etc/yum/pluginconf.d/versionlock.conf'

Comment 3 Tim Lauridsen 2007-02-14 11:57:04 UTC
I have also been fixed in the current yum-utils >= 1.0.x.


Note You need to log in before you can comment on or make changes to this bug.