Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225413 - Useless xen-vncfb process is created for fully virtualized domains
Summary: Useless xen-vncfb process is created for fully virtualized domains
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Markus Armbruster
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-30 15:18 UTC by Chris Lalancette
Modified: 2018-10-19 21:17 UTC (History)
2 users (show)

Fixed In Version: RHEA-2007-0635
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 17:09:34 UTC


Attachments (Terms of Use)
Rewrite old-style config into new style only for pv domains (deleted)
2007-01-30 15:59 UTC, Markus Armbruster
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0635 normal SHIPPED_LIVE xen enhancement update 2007-10-30 15:49:02 UTC

Description Chris Lalancette 2007-01-30 15:18:28 UTC
Description of problem:

When a fully virtualized domain is started (via xm create <dom>), a xen-vncfb
process is created.  However, fully virtualized domains do not require this for
the frame buffer, so it eats up a slot in the process table for no reason. 
Interestingly, the useless xen-vncfb process is not created when doing a fully
virt install via virt-install; only on subsequent reboots.

xenstore-ls shows a vkbd and vfb configured for the domain, so it seems
something is mis-configured.

This is pretty simple to reproduce; just install a fully virt domain (say, RHEL4
U4), shut it down, and then start it via "xm create"; you'll see the xen-vncfb
process created.

Comment 1 Markus Armbruster 2007-01-30 15:59:00 UTC
Created attachment 146926 [details]
Rewrite old-style config into new style only for pv domains

The PVFB backend (either xen-vncfb or xen-sdlfb) is only run when the device is
configured.  Unfortunately, fv configuration looks like old-style pv
configuration.	The backward compatibility code rewrites it into new style,
which makes it configured.  Don't do that.

Comment 2 RHEL Product and Program Management 2007-03-21 22:24:41 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Daniel Berrange 2007-06-14 15:02:31 UTC
Built into dist-5E-qu-candidate as xen-3.0.3-27.el5

* Thu Jun 14 2007 Daniel P. Berrange <berrange@redhat.com> - 3.0.3-27.el5
- Don't start a xen-vncfb process for HVM (rhbz#225413)


Comment 5 Issue Tracker 2007-08-06 19:04:13 UTC
Thanks for the update! I'll let engineering know it's fixed in the 5.1
bits.

Resolution set to: 'RHEL 5.1'
Ticket type set to: 'Problem'

This event sent from IssueTracker by gcase 
 issue 111215

Comment 8 errata-xmlrpc 2007-11-07 17:09:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0635.html



Note You need to log in before you can comment on or make changes to this bug.