Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225409 - Package Synchronization scheduled Error
Summary: Package Synchronization scheduled Error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 500
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-30 14:44 UTC by DCLUX sysadmin
Modified: 2012-03-16 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-16 16:38:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description DCLUX sysadmin 2007-01-30 14:44:27 UTC
Description of problem:

Package synchronization return an error on removing a package

----------------------------------------------------------------
This action will be executed after 2007-01-30 14:10:56 CET.

This action's status is: Failed.
The client picked up this action on 2007-01-30 14:14:49 CET.
The client completed this action on 2007-01-30 14:14:49 CET.
Client execution returned "Fatal error in Python code occured [[6]]" (code -1)
Changes Scheduled:

    * Remove nmap-4.11-1.1:2
------------------------------------------------------------------

Into /var/log/up2date file

[Tue Jan 30 15:16:11 2007] up2date 
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 271, in __run_action
    (status, message, data) = CheckCli.__do_call(method, params)
  File "/usr/sbin/rhn_check", line 264, in __do_call
    retval = method(*params)
  File "/usr/share/rhn/actions/packages.py", line 214, in runTransaction
    yum_base.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 441, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 194, in resolveDeps
    self.populateTs(test=1)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 174, in populateTs
    self.ts.addErase(txmbr.po.idx)
exceptions.AttributeError: YumAvailablePackageSqlite instance has no attribute 'idx'


Version-Release number of selected component (if applicable):

5.0

How reproducible:

Always

Steps to Reproduce:
1. Create a system
2. Register the system to RHN 5 Beta
3. Create a Package Profile for the system
4. Install a new package, like nmap
5. Make a Package profile comparaison.
6. Sync the nmap package to the package profile (aka removing package profile)
7. Schedule the sync
8. During schedule tail -f /var/log/up2date
9. Read the system history events where you can find the error
  
Actual results:

nmap package is not removed. Package Synchronisation scheduled don't work

Expected results:

Package Synchronisation scheduled should remove or install the packages

Additional info:

Comment 2 Miroslav Suchý 2012-03-16 16:38:29 UTC
I could not reproduce it on RHEL5.7 and RHN Satellite 5.4.1


Note You need to log in before you can comment on or make changes to this bug.