Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225389 - Missing "libstdc++-libc6.1-1.so.2"
Summary: Missing "libstdc++-libc6.1-1.so.2"
Keywords:
Status: CLOSED DUPLICATE of bug 225371
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-gcc-296
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-30 10:31 UTC by Akira Eto
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-30 10:49:43 UTC


Attachments (Terms of Use)
Missing "libstdc++-libc6.1-1.so.2" (deleted)
2007-01-30 10:31 UTC, Akira Eto
no flags Details

Description Akira Eto 2007-01-30 10:31:21 UTC
Description of problem:

Software Error occurred: "SiteMinder" Apache/Linux Agent 4.6.1
Vendor: CA / Netegrity
Module Name: mod_sm.so

Due to Missing "libstdc++-libc6.1-1.so.2",
"SiteMinder" Apache/Linux Agent 4.6.1 does not work.
Module for Apache "mod_sm.so" depends on "libstdc++-libc6.1-1.so.2",
but "compat-libstdc++-296-2.96-138.i386.rpm"(for FC-6) does not include it.
Therefore "mod_sm.so" does not work on FC-6.
On FC-5, "compat-libstdc++-296-2.96-135.i386.rpm"(for FC-5) includes
"libstdc++-libc6.1-1.so.2",and "mod_sm.so" works fine.


Version-Release number of selected component (if applicable):

compat-libstdc++-296-2.96-138.i386.rpm


How reproducible:

Add to httpd.conf with

#LoadModule sm_module
PassEnv LD_LIBRARY_PATH "/opt/netegrity/siteminder/webagent/lib"
LoadModule sm_module /opt/netegrity/siteminder/webagent/lib/mod_sm.so
SmInitFile /etc/apache/conf/WebAgent.conf

Then ./apachectl start


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Module for Apache "mod_sm.so" depends on "libstdc++-libc6.1-1.so.2",
but "compat-libstdc++-296-2.96-138.i386.rpm"(for FC-6) does not include it.
Therefore "mod_sm.so" does not work on FC-6.


Expected results:

Like FC-5 "compat-libstdc++-296-2.96-135.i386.rpm"(for FC-5),
includes "libstdc++-libc6.1-1.so.2",
and "mod_sm.so" works fine.


Additional info:

Please fix "compat-libstdc++-296-2.96-138.i386.rpm"(for FC-6)
and keep compatibility with old Modules like "mod_sm.so".
See attached file of Terminal.
Thank you.

Comment 1 Akira Eto 2007-01-30 10:31:21 UTC
Created attachment 146905 [details]
Missing "libstdc++-libc6.1-1.so.2"

Comment 2 Jakub Jelinek 2007-01-30 10:49:43 UTC

*** This bug has been marked as a duplicate of 225371 ***


Note You need to log in before you can comment on or make changes to this bug.