Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225372 - Calendar appointments aren't saved on Exchange server
Summary: Calendar appointments aren't saved on Exchange server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-30 07:12 UTC by Per Nystrom
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: evolution-data-server-1.8.3-3.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-07 23:35:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 301363 None None None Never

Description Per Nystrom 2007-01-30 07:12:57 UTC
Description of problem:  I make an appointment on the Exchange server, quit
Evolution, restart, and the appointment is no longer there!


Version-Release number of selected component (if applicable):
evolution-connector-2.8.2-2.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Make an appointment on an exchange calendar and save it.
2. Quite Evolution.
3. Restart, the appointment is gone!
4. Looking at the Exchange server through OWA, I can see that the appointments I
make in Evolution never appear at all!
  
Actual results:


Expected results:
Exchange calendar appointments need to actually be saved to the server!

Additional info:
This is not something I've seen in all the previous versions of Evolution I've
used and it's very disturbing.  Evolution behaves as though the saved
appointment is actually on the Exchange server, but as soon as I quit and
restart, it's gone.

Comment 1 Per Nystrom 2007-01-31 06:19:50 UTC
Here's what Evolution spits out in the terminal I run it from when I make an
appointment on the exchange calendar:

(evolution:27791): libecal-WARNING **: e-cal.c:321: Unexpected response

(evolution:27791): libecal-WARNING **: e-cal.c:321: Unexpected response

(evolution:27791): calendar-gui-CRITICAL **: e_day_view_add_event: assertion
`end > add_event_data->day_view->lower' failed

(evolution:27791): calendar-gui-CRITICAL **: e_week_view_add_event: assertion
`end > add_event_data->week_view->day_starts[0]' failed

Comment 2 Per Nystrom 2007-02-02 01:30:31 UTC
Same bug is reported in Gnome's bugzilla:
http://bugzilla.gnome.org/show_bug.cgi?id=394473

Comment 3 Per Nystrom 2007-02-19 07:42:47 UTC
This is killing my productivity in FC6, I'd like to try to downgrade evolution
until it's fixed but I can't seem to get the FC5 srpm to compile.  Any ideas?

(This is what I get when trying to build the FC5 srpm)

make[3]: *** No rule to make target `../../mail/libevolution-mail.la', needed by
`liborg-gnome-evolution-mail-attachments-import-ics.la'.  Stop.
make[3]: *** Waiting for unfinished jobs....

Comment 4 Per Nystrom 2007-03-07 06:55:13 UTC
I found out through poking the Evolution mailing list that there is a fix here:

http://bugzilla.gnome.org/attachment.cgi?id=83954

referenced from this bug here:

http://bugzilla.gnome.org/show_bug.cgi?id=301363#c37

I've applied the patch to my system and it seems to work.  Can we get it
included in an update to evolution-data-server?  (When I have more time I'll
work up an SRPM that includes it, if that helps.)

Comment 5 Matthew Barnes 2007-03-07 11:23:20 UTC
Already done.  Should hit Fedora Updates Testing in the next day or so.

evolution-data-server-1.8.3-3.fc6

Comment 6 Matthew Barnes 2007-03-07 23:35:19 UTC
Closing since the package is now in Fedora Updates Testing.  Feel free to reopen
this bug if you find that the problem has not been corrected.


Note You need to log in before you can comment on or make changes to this bug.