Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225363 - upgraded some packages yesterday now FC6 does not have eth0 connectivity
Summary: upgraded some packages yesterday now FC6 does not have eth0 connectivity
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 6
Hardware: i686
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-30 05:30 UTC by Grady Rhodes
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 18:34:55 UTC


Attachments (Terms of Use)
cronological list of last installed packages (deleted)
2007-01-30 05:58 UTC, Grady Rhodes
no flags Details
/var/log/messages for failing eth0 conectivity (deleted)
2007-02-02 20:14 UTC, Grady Rhodes
no flags Details
/var/log/audit.log (deleted)
2007-02-03 01:16 UTC, Grady Rhodes
no flags Details
/var/log/messages full content (deleted)
2007-02-03 01:22 UTC, Grady Rhodes
no flags Details

Description Grady Rhodes 2007-01-30 05:30:50 UTC
Description of problem:
I boot daily and check news sites on the web.  I updated some packages on
1/18/07 and had no problems (this included the current kernel at that time).
Then yesterday (1/28/07), I used the Software Updater again and when I rebooted
today, I no longer have network connectivity on eth0.  I can boot into both
WinME and RH7.1 which both have network connectivity through the same ethernet
port/cable.  I have booted FC6 about 5 times now and it always has this problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. boot
2.
3.

Actual results:


Expected results:


Additional info:

I need some suggestions to track this down some more.

Comment 1 Grady Rhodes 2007-01-30 05:58:43 UTC
Created attachment 146888 [details]
cronological list of last installed packages

This file lists the packages that I installed/updated with the Software Updater
tool.  I did not have a problem with anything until today (I boot daily).

Comment 2 Grady Rhodes 2007-01-30 06:04:46 UTC
My current kernel is 2.6.19-1.2895.fc6 it worked fine from 1/18/07 until
1/28/07.  After the Software Updater was run on 1/28/07 now the eth0 does not
connect.

Comment 3 Grady Rhodes 2007-02-02 20:14:12 UTC
Created attachment 147250 [details]
/var/log/messages for failing eth0 conectivity

 Search in file for first "eth0" and look at next line.  It appears to me that
SELinux is not allowing the DHCP client from running.  Is this correct?  If so,
how do I fix this (preferable not downloading something since I don't have a
network)?

Comment 4 Grady Rhodes 2007-02-02 23:41:45 UTC
I am backup.  I simply disabled SELinux (edited /etc/selinux/config and changed
the line "SELINUX=enforcing" to "SELINUX=disabled") then rebooted and now eth0
works again.

From my list of packages installed on 28-Jan-07 there are two for SELinux.

selinux-policy-targeted-2.4.6-27.fc6          Sun 28 Jan 2007 12:29:00 PM MST
selinux-policy-2.4.6-27.fc6                   Sun 28 Jan 2007 12:28:57 PM MST

Please fix the SELinux policy package(s) so folks network connectivity does not
stop on them.

Comment 5 Grady Rhodes 2007-02-03 01:16:44 UTC
Created attachment 147267 [details]
/var/log/audit.log 

Saw bug# 222669 (network problem after reboot with new mount in /var).
So I'm including /var/log/audit.log and /var/log/messages.

Comment 6 Grady Rhodes 2007-02-03 01:22:31 UTC
Created attachment 147268 [details]
/var/log/messages full content

Comment 7 Daniel Walsh 2007-02-05 18:34:55 UTC
You have a labeling problem on dhclient-script

restorecon dhclient-script should fix the problem.

Looks like you edited this file in a home directory and then moved it to the
system directory, which maintained the home directory file context. restorecon
will set the file context to its correct context.  You probably should install
setroubleshoot to help you debug problems in the future.  Or at least indicate
right away that SELinux is causing the problem.


Note You need to log in before you can comment on or make changes to this bug.