Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225329 - Build of eclipse-cdt bogged down by warnings
Summary: Build of eclipse-cdt bogged down by warnings
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 22:13 UTC by Jeff Johnston
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.2.2-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-21 21:43:47 UTC


Attachments (Terms of Use)

Description Jeff Johnston 2007-01-29 22:13:05 UTC
Description of problem:
Attempting to build eclipse-cdt for FC6 is getting bogged down with access
restriction warnings of the type:

    [javac] 74. WARNING in
/builddir/build/BUILD/eclipse-cdt-3.1.1/org.eclipse.cdt.releng/results/plugins/org.eclipse.cdt.core/src/org/eclipse/cdt/core/CConventions.java
    [javac]  (at line 181)
    [javac] 	return new Status(IStatus.WARNING, CCorePlugin.PLUGIN_ID, -1,
Util.bind("convention.namespace.dollarName"), null); //$NON-NLS-1$
    [javac] 	                          ^^^^^^^
    [javac] Access restriction: The field WARNING from the type IStatus is not
accessible due to restriction on classpath entry
/builddir/build/BUILD/eclipse-cdt-3.1.1/SDK/plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar
 

Version-Release number of selected component (if applicable):

How reproducible:

Attempt to build eclipse-cdt rpm under FC6 brew.

 
Actual results:

Very slow build with warnings on every line.

Expected results:

Reasonably quick build.

Additional info:

Problem does not appear to be in rawhide.  Same rpm sources built quickly there.

Comment 1 Ben Konrath 2007-01-29 22:26:40 UTC
This is caused by a bug in the ecj-square-brakets patch. I just fixed it in
rawhide so I'll push an update to FC6 with the updated patch. Thanks.

Comment 2 Ben Konrath 2007-02-21 21:43:47 UTC
This is fixed in the upcoming 3.2.2-1.fc6 update. Thanks.


Note You need to log in before you can comment on or make changes to this bug.