Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225212 - frysk command line rpm missing from client
Summary: frysk command line rpm missing from client
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: comps
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dennis Gregorovic
QA Contact: Len DiMaggio
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 19:46 UTC by Rick Moseley
Modified: 2007-11-30 22:07 UTC (History)
10 users (show)

Fixed In Version: 5.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 14:58:27 UTC


Attachments (Terms of Use)

Description Rick Moseley 2007-01-29 19:46:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061221 Fedora/1.5.0.9-1.fc5 Firefox/1.5.0.9

Description of problem:
I downloaded and installed the latest RHEL5 Client iso's dated 20070126.  When I tried to install frysk via the "yum install frysk", I found that neither "frysk" nor its dependencies(i.e. glib-java-devel) are in the channel for Client.

Version-Release number of selected component (if applicable):
yum install frysk

How reproducible:
Always


Steps to Reproduce:
1. Install RHEL5 Client iso.
2. Try to install frysk with "yum install frysk"
3.

Actual Results:
[root@frysk64 ~]# yum install frysk
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Install Process
Setting up repositories
rhel-x86_64-client-5      100% |=========================| 1.2 kB    00:00
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: frysk
Nothing to do


Expected Results:
Should install frysk.

Additional info:

Comment 1 Dennis Gregorovic 2007-02-01 17:45:47 UTC
frysk is part of the workstation option.  You will need to have the necessary
entitlements for workstation and make sure that you are subscribed to the
workstation child channel in RHN.

Comment 2 Andrew Cagney 2007-02-02 22:21:29 UTC
The underlying question here is what tools should be included in the client ISO
as they are useful as syadmin tools.

Looking at the client iso gcc, systemtap, and gdb are present, but frysk is not.

Comment 3 RHEL Product and Program Management 2007-02-02 22:41:15 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Dennis Gregorovic 2007-02-04 22:20:49 UTC
I've made a change to comps.xml that moves frysk from workstation to Client Core.  

Comment 5 James Laska 2007-02-05 14:53:57 UTC
cagney: frysk is on the the client ISO ... it's just not enabled unless you have
a workstation installation number.  Also, I suspect since frysk is tech-preview
having it on the Workstation option is intentional?

Daniel?

Comment 6 Andrew Cagney 2007-02-05 17:33:00 UTC
The command line utilties are "supported", the graphical interface is still
tech-preview.


Comment 7 James Laska 2007-02-05 19:20:19 UTC
Does this mean moving just the base frysk package, or moving all frysk subpackages?

RHEL5-Client-20070126.0/tree-x86_64/Workstation/frysk-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
RHEL5-Client-20070126.0/tree-x86_64/Workstation/frysk-devel-0.0.1.2006.12.22.rh1-4.el5.i686.rpm
RHEL5-Client-20070126.0/tree-x86_64/Workstation/frysk-devel-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
RHEL5-Client-20070126.0/tree-x86_64/Workstation/frysk-gnome-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm

Comment 8 Dennis Gregorovic 2007-02-05 19:44:05 UTC
RHEL5-Client-20070203.nightly/tree-x86_64/Client/frysk-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
RHEL5-Client-20070203.nightly/tree-x86_64/Client/frysk-gnome-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
RHEL5-Client-20070203.nightly/tree-x86_64/Workstation/frysk-devel-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
RHEL5-Client-20070203.nightly/tree-x86_64/Workstation/frysk-devel-0.0.1.2006.12.22.rh1-4.el5.i686.rpm


Comment 9 James Laska 2007-02-05 20:18:28 UTC
Installing frysk and frysk-gnome on a Client-only install appears to not pull in
unwanted dependencies.

$ yum localinstall frysk-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
frysk-gnome-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 frysk                   x86_64     0.0.1.2006.12.22.rh1-4.el5 
/mnt/redhat/rel-eng/RHEL5-Client-20070126.0/tree-x86_64/Workstation/frysk-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
  28 M
 frysk-gnome             x86_64     0.0.1.2006.12.22.rh1-4.el5 
/mnt/redhat/rel-eng/RHEL5-Client-20070126.0/tree-x86_64/Workstation/frysk-gnome-0.0.1.2006.12.22.rh1-4.el5.x86_64.rpm
  11 M
Installing for dependencies:
 cairo-java              x86_64     1.0.5-3.fc6      rhel-x86_64-client-5  196 k
 glib-java               x86_64     0.2.6-3.fc6      rhel-x86_64-client-5   57 k
 libgconf-java           x86_64     2.12.4-6.el5     rhel-x86_64-client-5   74 k
 libglade-java           x86_64     2.12.5-3.fc6     rhel-x86_64-client-5  100 k
 libgnome-java           x86_64     2.12.4-3.fc6     rhel-x86_64-client-5  471 k
 libgtk-java             x86_64     2.8.7-3.el5      rhel-x86_64-client-5  2.2 M
 libvte-java             x86_64     0.12.1-6.el5     rhel-x86_64-client-5   74 k


Package moves between options are very concerning at this point.  While this is
just two packages moving around, package add/moves/deletes have been known to
cause a trickle affect that could potentially disrupt the distrobution.  I'm
ACKing this fix for 5.0.  


Note You need to log in before you can comment on or make changes to this bug.