Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225199 - gfs_quota hangs in do_list()
Summary: gfs_quota hangs in do_list()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-utils
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Abhijith Das
QA Contact: GFS Bugs
URL:
Whiteboard:
Depends On:
Blocks: 430133 430134
TreeView+ depends on / blocked
 
Reported: 2007-01-29 18:41 UTC by Abhijith Das
Modified: 2010-01-12 03:32 UTC (History)
0 users

Fixed In Version: RHBA-2007-0576
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 17:57:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0576 normal SHIPPED_LIVE gfs-utils bug fix update 2007-10-30 15:36:03 UTC

Description Abhijith Das 2007-01-29 18:41:37 UTC
Description of problem:
gfs_quota list -f /fs/path appears to hang when the hidden quota file becomes an
unmanageably large sparse file. Duplicate of RHEL4 bug bz210362

The gfs_quota tool sequentially reads the quota file ignorant of large holes in
the quota file which takes a lot of time. The gfs_quota tool needs to
intelligently skip the holes in the file and only read quota file information
that's on actual data-filled blocks.

Comment 1 Abhijith Das 2007-04-04 21:39:51 UTC
cvs commit -m "fix for bug 225199 - Same as GFS1 fix in RHEL4 (bug 210362). We
don't run throug the entire gfs_quota sparse file to do a list operation
anymore. We get the layout of the gfs_quota file on disk and only read quota
information off the data blocks that are actually in use. Also added
functionality to GFS_IOCTL_SUPER to provide the metadata of the hidden quota
file." gfs-kernel/src/gfs/ioctl.c gfs/gfs_quota/layout.c gfs/gfs_quota/Makefile
gfs/gfs_quota/main.c gfs/gfs_quota/gfs_quota.h

Checking in gfs-kernel/src/gfs/ioctl.c;
/cvs/cluster/cluster/gfs-kernel/src/gfs/ioctl.c,v  <--  ioctl.c
new revision: 1.15; previous revision: 1.14
done
Checking in gfs/gfs_quota/layout.c;
/cvs/cluster/cluster/gfs/gfs_quota/layout.c,v  <--  layout.c
new revision: 1.2; previous revision: 1.1
done
Checking in gfs/gfs_quota/Makefile;
/cvs/cluster/cluster/gfs/gfs_quota/Makefile,v  <--  Makefile
new revision: 1.6; previous revision: 1.5
done
Checking in gfs/gfs_quota/main.c;
/cvs/cluster/cluster/gfs/gfs_quota/main.c,v  <--  main.c
new revision: 1.4; previous revision: 1.3
done
Checking in gfs/gfs_quota/gfs_quota.h;
/cvs/cluster/cluster/gfs/gfs_quota/gfs_quota.h,v  <--  gfs_quota.h
new revision: 1.3; previous revision: 1.2
done


This fix takes care of the problem in gfs1. But the issue still exists for GFS2
(bug 235299).

Comment 2 Kiersten (Kerri) Anderson 2007-04-23 17:39:21 UTC
Fixing product name. Cluster Suite components were integrated into Enterprise
Linux for verion 5.0.

Comment 5 errata-xmlrpc 2007-11-07 17:57:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0576.html



Note You need to log in before you can comment on or make changes to this bug.