Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225188 - Charset handling is less than perfect
Summary: Charset handling is less than perfect
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: unrtf
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 17:53 UTC by Robert Vogelgesang
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-03 10:00:41 UTC


Attachments (Terms of Use)
Workaround/fix for codepage problems (deleted)
2007-01-29 17:53 UTC, Robert Vogelgesang
no flags Details | Diff

Description Robert Vogelgesang 2007-01-29 17:53:41 UTC
Description of problem:
Recent versions of unrtf have "improved" codepage support, but when
converting RTFs e. g. using codepage 1252, the "umlauts" are not properly
handled.  Earlier versions of unrtf did manage to convert these characters.

Version-Release number of selected component (if applicable):
0.20.2 and earlier

How reproducible:
Always when converting RTFs using codepage 1252 with umlauts's.

Steps to Reproduce:
1. unrtf --html RTF.rtf
2.
3.
  
Actual results:
The generated HTML contains HTML comments that specify the hex code of the
umlaut characters.

Expected results:
No added HTML comments, but instead properly converted umlauts.

Additional info:
See the attached patch for a fix.  This patch was also submitted to the
upstream maintainers, but without response from them since October 2006.

Comment 1 Robert Vogelgesang 2007-01-29 17:53:44 UTC
Created attachment 146844 [details]
Workaround/fix for codepage problems

Comment 2 Aurelien Bompard 2007-03-03 10:00:41 UTC
Patch applied in release 2, thanks


Note You need to log in before you can comment on or make changes to this bug.