Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225187 - Crash on startup after recent yum update
Summary: Crash on startup after recent yum update
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-01-29 17:50 UTC by Pete Zaitcev
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-25 19:52:56 UTC


Attachments (Terms of Use)
bug-buddy log (deleted)
2007-01-29 17:52 UTC, Pete Zaitcev
no flags Details
bug-buddy log (deleted)
2007-01-29 20:41 UTC, Pete Zaitcev
no flags Details
bug-buddy with all debuginfos (deleted)
2007-01-30 17:23 UTC, Pete Zaitcev
no flags Details

Description Pete Zaitcev 2007-01-29 17:50:56 UTC
Description of problem:

On every startup, bug-buddy dialog appears because gnome-power-manager
crashes. This started to happen after an update.

Version-Release number of selected component (if applicable):

gnome-power-manager-2.17.90-1.fc7

How reproducible:

Happens every time on login, but not known how to reproduce on demand

Steps to Reproduce:
1. Log out and log in
  
Actual results:

Crash

Expected results:

No crash

Additional info:

Last known good version is 2.17.4-1.fc7

Comment 1 Pete Zaitcev 2007-01-29 17:52:17 UTC
Created attachment 146842 [details]
bug-buddy log

Unfortunately, there's no debuginfo. Is there an easy way to install it?

Comment 2 Richard Hughes 2007-01-29 19:47:56 UTC
yum install gnome-power-manager-debuginfo when you've enabled the debuginfo repo
in /etc/yum.repos.d? THe answer to your last question is no, and it should be
really easy.

Could you try SVN? This sounds like http://bugzilla.gnome.org/show_bug.cgi?id=400654

Comment 3 Pete Zaitcev 2007-01-29 20:40:28 UTC
Ah yes, thanks. It turned out that our mirrorlist does not support debuginfo,
but entering the baseurl by hand works, so I have a better backtrace now.

But it seems not to have anything to with icons, and dbus is involved.


Comment 4 Pete Zaitcev 2007-01-29 20:41:37 UTC
Created attachment 146864 [details]
bug-buddy log

Comment 5 Richard Hughes 2007-01-29 20:49:53 UTC
Looks like dbus went pop. Could you install the dbus and dbus-glib debug info,
and also try to run "gnome-power-manager --verbose --no-daemon". Many thanks.

Comment 6 Pete Zaitcev 2007-01-30 17:23:44 UTC
Created attachment 146932 [details]
bug-buddy with all debuginfos

Comment 7 Pete Zaitcev 2007-01-30 17:25:49 UTC
The program does not crash when run from command line.

[zaitcev@simbelmyne ~]$ gnome-power-manager --verbose --no-daemon
[gpm_debug_init] gpm-debug.c:217 (09:23:02):     Verbose debugging enabled
[gpm_proxy_connect] gpm-proxy.c:99 (09:23:02):   emitting proxy-status TRUE:
org.freedesktop.Hal
[gpm_proxy_connect] gpm-proxy.c:99 (09:23:02):   emitting proxy-status TRUE:
org.freedesktop.Hal
*** WARNING ***
[gpm_ac_adapter_init] gpm-ac-adapter.c:204 (09:23:02):   No devices of
capability ac_adapter
[gpm_control_init] gpm-control.c:833 (09:23:02):         Using a supressed
policy timeout of 5 seconds
[gpm_refcount_add] gpm-refcount.c:101 (09:23:02):        refcount now: 1
[gpm_refcount_add] gpm-refcount.c:102 (09:23:02):        non zero, so sending
REFCOUNT_ADDED
[gpm_power_refcount_added] gpm-power.c:138 (09:23:02):   Data is now not trusted
[gpm_hash_new_kind_cache] gpm-power.c:1712 (09:23:02):   creating cache
[gpm_hash_new_device_cache] gpm-power.c:1746 (09:23:02):         creating cache
[gpm_warning_init] gpm-warning.c:260 (09:23:02):         Using per-time
notification policy
[gpm_proxy_connect] gpm-proxy.c:99 (09:23:02):   emitting proxy-status TRUE:
org.gnome.ScreenSaver
[gpm_idle_set_check_cpu] gpm-idle.c:306 (09:23:02):      Setting the CPU load
check to 0
[gpm_manager_init] gpm-manager.c:1549 (09:23:02):        creating new inhibit
instance
[gpm_manager_init] gpm-manager.c:1560 (09:23:02):        creating new control
instance
[gpm_manager_init] gpm-manager.c:1570 (09:23:02):        creating new tray icon
[gpm_manager_init] gpm-manager.c:1579 (09:23:02):        initialising info
infrastructure
[gpm_hal_is_laptop] gpm-hal.c:1194 (09:23:02):   This machine is not identified
as a laptop.system.formfactor is desktop.
[gpm_hal_is_laptop] gpm-hal.c:1194 (09:23:02):   This machine is not identified
as a laptop.system.formfactor is desktop.
[gpm_hal_enable_power_save] gpm-hal.c:1474 (09:23:02):   We are not a laptop, so
not even trying
[gpm_idle_set_system_timeout] gpm-idle.c:357 (09:23:02):         Setting system
idle timeout: 0
[get_stock_id] gpm-tray-icon.c:680 (09:23:02):   Trying CRITICAL icon: primary,
ups, mouse, keyboard
[get_stock_id] gpm-tray-icon.c:704 (09:23:02):   Trying CHARGING icon: primary, ups
[get_stock_id] gpm-tray-icon.c:721 (09:23:02):   Trying PRESENT icon: primary, ups
[get_stock_id] gpm-tray-icon.c:736 (09:23:02):   Using fallback
[gpm_tray_icon_sync] gpm-tray-icon.c:763 (09:23:02):     Going to use stock id:
gpm-ac-adapter
[gpm_tray_icon_set_image_from_stock] gpm-tray-icon.c:155 (09:23:02):    
emitting icon-changed
[gpm_tray_icon_set_image_from_stock] gpm-tray-icon.c:161 (09:23:02):     Setting
icon to gpm-ac-adapter
[gpm_tray_icon_sync] gpm-tray-icon.c:774 (09:23:02):     emitting
description-changed
[gpm_refcount_auto_decrement] gpm-refcount.c:75 (09:23:03):      zero, so
sending REFCOUNT_ZERO
[gpm_power_refcount_zero] gpm-power.c:123 (09:23:03):    Data is now trusted
[get_stock_id] gpm-tray-icon.c:680 (09:23:03):   Trying CRITICAL icon: primary,
ups, mouse, keyboard
[get_stock_id] gpm-tray-icon.c:704 (09:23:03):   Trying CHARGING icon: primary, ups
[get_stock_id] gpm-tray-icon.c:721 (09:23:03):   Trying PRESENT icon: primary, ups
[get_stock_id] gpm-tray-icon.c:736 (09:23:03):   Using fallback
[gpm_tray_icon_sync] gpm-tray-icon.c:763 (09:23:03):     Going to use stock id:
gpm-ac-adapter
[gpm_tray_icon_set_image_from_stock] gpm-tray-icon.c:155 (09:23:03):    
emitting icon-changed
[gpm_tray_icon_sync] gpm-tray-icon.c:774 (09:23:03):     emitting
description-changed
[gpm_power_get_status_summary] gpm-power.c:1436 (09:23:03):      tooltip:
Computer is running on AC power
[battery_status_changed_primary] gpm-manager.c:954 (09:23:03):   Laptop battery
is not discharging



Comment 8 Pete Zaitcev 2007-01-30 17:30:58 UTC
Actually, I tried it a few times, and it looks like some kind of a race.
If I run gnome-power-manager --verbose --no-daemon as requested, sometimes
it works, sometimes it exits with return code 1. It's random. If I run it
without arguments, sometimes it works, sometimes crashes with the same
traceback.


Comment 9 Richard Hughes 2007-02-01 20:24:29 UTC
Could you try SVN trunk from a few minutes ago please?

Comment 10 Pete Zaitcev 2007-02-05 08:04:39 UTC
Unfortunately, building from the source is not easily done here, so I'll have
to wait until it turns around through David.

Comment 11 Will Woods 2007-03-24 19:37:19 UTC
There's been a few weeks' worth of updates - does this work in current rawhide?

Comment 12 Pete Zaitcev 2007-03-25 19:52:56 UTC
Seems working now.
gnome-power-manager-2.18.0-1.fc7



Note You need to log in before you can comment on or make changes to this bug.