Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225184 - Handling of embedded pictures in RTF docs is broken
Summary: Handling of embedded pictures in RTF docs is broken
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: unrtf
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 17:41 UTC by Robert Vogelgesang
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-03 10:00:44 UTC


Attachments (Terms of Use)
Fix handling of embedded pictures (deleted)
2007-01-29 17:41 UTC, Robert Vogelgesang
no flags Details | Diff

Description Robert Vogelgesang 2007-01-29 17:41:50 UTC
Description of problem:
Recent versions of unrtf produce "funny" output when converting RTFs with
embedded pictures.

Version-Release number of selected component (if applicable):
0.20.2 and earlier

How reproducible:
Always with RTFs containing \pict's.

Steps to Reproduce:
1. unrtf --html RTF.rtf
2.
3.
  
Actual results:
The generated HTML contains the ASCII representation of the picture data.

Expected results:
"Clean" HTML output.

Additional info:
See the attached patch for a fix.  This patch was also submitted to the
upstream maintainers, but without response from them since October 2006.

Comment 1 Robert Vogelgesang 2007-01-29 17:41:50 UTC
Created attachment 146840 [details]
Fix handling of embedded pictures

Comment 2 Aurelien Bompard 2007-03-03 10:00:44 UTC
Patch applied in release 2, thanks


Note You need to log in before you can comment on or make changes to this bug.