Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225154 - NFSv4 shouldn't need portmap service
Summary: NFSv4 shouldn't need portmap service
Keywords:
Status: CLOSED DUPLICATE of bug 227602
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jeff Layton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 14:46 UTC by Ramon Acedo
Modified: 2012-05-19 23:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-09 00:35:51 UTC


Attachments (Terms of Use)

Description Ramon Acedo 2007-01-29 14:46:10 UTC
Description of problem:

According to our reference manual nfs4 doesn't need any more the
portmapper:
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/ref-
guide/ch-nfs.html#S1-NFS-HOW

But if the portmapper is not started in the client the NFS share cannot be mounted. 

Version-Release number of selected component (if applicable):

RHEL4U4 (nfs-utils-1.0.6-70.EL4) and RHEL5

Steps to Reproduce:

Server:

# cat /etc/exports
/home/samba       dhcp-0-178(rw,fsid=0,insecure)

Client with portmapper:

# mount -t nfs4 racedo:/ /mnt/ && echo $?
0

Client without portmapper:

# mount -t nfs4 racedo:/ /mnt/ 

takes forever... and in the logs:

Dec 23 08:36:09 dhcp-0-178 kernel: portmap: server localhost not
responding, timed out
Dec 23 08:36:09 dhcp-0-178 kernel: RPC: failed to contact portmap (errno
-5)

Comment 1 RHEL Product and Program Management 2007-03-21 22:25:29 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Jeff Layton 2007-05-09 00:35:51 UTC

*** This bug has been marked as a duplicate of 227602 ***


Note You need to log in before you can comment on or make changes to this bug.