Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225138 - yum update report "No such file or directory: '/etc/pki/rpm-gpg/RPM-GPG-KEY-beta"
Summary: yum update report "No such file or directory: '/etc/pki/rpm-gpg/RPM-GPG-KEY-b...
Keywords:
Status: CLOSED DUPLICATE of bug 220354
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: yum
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 10:55 UTC by Leon Li
Modified: 2013-01-10 10:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-29 15:12:42 UTC


Attachments (Terms of Use)

Description Leon Li 2007-01-29 10:55:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

Description of problem:
[root@leonli2 tree-i386]# yum update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5-beta   100% |=========================|  950 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ImageMagick.i386 0:6.2.8.0-3.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 ImageMagick             i386       6.2.8.0-3.fc6    rhel-i386-server-5-beta  3.3 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 3.3 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 897da07a


GPG key retrieval failed: [Errno 5] OSError: [Errno 2] No such file or directory: '/etc/pki/rpm-gpg/RPM-GPG-KEY-beta'

Version-Release number of selected component (if applicable):
RHEL 4.92 (Tikanga) 20070112.3

How reproducible:
Always


Steps to Reproduce:
1.yum update 
2.
3.

Actual Results:
[root@leonli2 tree-i386]# yum update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5-beta   100% |=========================|  950 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ImageMagick.i386 0:6.2.8.0-3.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 ImageMagick             i386       6.2.8.0-3.fc6    rhel-i386-server-5-beta  3.3 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 3.3 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 897da07a


GPG key retrieval failed: [Errno 5] OSError: [Errno 2] No such file or directory: '/etc/pki/rpm-gpg/RPM-GPG-KEY-beta'


Expected Results:
[root@leonli2 rpm-gpg]# yum update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5-beta   100% |=========================|  950 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ImageMagick.i386 0:6.2.8.0-3.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 ImageMagick             i386       6.2.8.0-3.fc6    rhel-i386-server-5-beta  3.3 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 3.3 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 897da07a
Importing GPG key 0x897DA07A "Red Hat, Inc. (Beta Test Software) <rawhide@redhat.com>"
Is this ok [y/N]: y
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : ImageMagick                  ######################### [1/2]
  Cleanup   : ImageMagick                  ######################### [2/2]

Updated: ImageMagick.i386 0:6.2.8.0-3.fc6
Complete!

Additional info:
After I run 

[root@leonli2 tree-i386]# cd /etc/pki/rpm-gpg/
[root@leonli2 rpm-gpg]# cp RPM-GPG-KEY-redhat-beta  RPM-GPG-KEY-beta

it works well as expected results

Comment 1 James Bowes 2007-01-29 15:12:42 UTC

*** This bug has been marked as a duplicate of 220354 ***


Note You need to log in before you can comment on or make changes to this bug.