Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225116 - gnucash-2.0.4-1.fc6.i386.rpm seems to be incomplete
Summary: gnucash-2.0.4-1.fc6.i386.rpm seems to be incomplete
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libtool
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
: 227131 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-29 02:41 UTC by david.hagood
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-08 15:41:13 UTC


Attachments (Terms of Use)
output from running GnuCash (deleted)
2007-01-29 02:41 UTC, david.hagood
no flags Details

Description david.hagood 2007-01-29 02:41:16 UTC
Description of problem:
gnucash-2.0.4-1.fc6.i386.rpm seems to be incomplete - after upgrading GnuCash
does not run, and generates errors on stderr.

Version-Release number of selected component (if applicable):
2.0.4-1.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Install or upgrade to 2.0.4-1.fc6
2. run gnucash

  
Actual results:
GnuCash bombs with error messages

Expected results:
GnuCash should run

Additional info:

Comment 1 david.hagood 2007-01-29 02:41:16 UTC
Created attachment 146804 [details]
output from running GnuCash

Comment 2 Bill Nottingham 2007-01-29 16:26:43 UTC
They're in the package. What does 'rpm -V gnucash' say?

Comment 3 david.hagood 2007-01-29 17:18:45 UTC
They are in the package and verify as OK.

I've also tried falling back to the 2.0.2 version of GnuCash and it now is
broken - so *something else* is causing the problems. However, I have no idea
WHAT would cause these errors. Any suggestions?


Comment 4 Bill Nottingham 2007-01-29 17:47:34 UTC
Check your guile and g-wrap installation?

Comment 5 david.hagood 2007-01-29 22:39:01 UTC
 rpm -q guile g-wrap
guile-1.8.1-2.fc7
g-wrap-1.9.6-7.1

 rpm -V guile g-wrap
prelink: /usr/lib/libgwrap-core-runtime.so.0.0.1: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/libgwrap-core-runtime.so.0.0.1
prelink: /usr/lib/libgwrap-guile-runtime.so.0.0.2: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/libgwrap-guile-runtime.so.0.0.2

Any advice on specific things to check?


Comment 6 Bill Nottingham 2007-01-30 17:18:40 UTC
Not sure. I'm assuming removal-and-reinstall doesn't fix it?

Comment 7 david.hagood 2007-01-30 23:32:55 UTC
I've removed and reinstalled GnuCash - no effect.

I have the same version of GnuCash working on different machine, however that
machine has guile-1.8.1-1.fc7.

Updating that other machine to guile-1.8.1-2.fc7 broke it, so the fault lies in
guile-1.8.1-2.fc7, and was not in guile-1.8.1-1.fc7.



Comment 8 Bill Nottingham 2007-01-31 02:35:42 UTC
Can you do a strace of it and attach it?

Comment 9 Bill Nottingham 2007-01-31 02:36:54 UTC
Never mind, finally reproduced.

Comment 10 Miroslav Lichvar 2007-01-31 15:58:16 UTC
Hm, it fails even with guile-1.8.1-1.fc7 and slib-3a3-2. I also remember testing
gnucash when doing the last guile and slib update.


Comment 11 Miroslav Lichvar 2007-02-01 12:11:31 UTC
Downgrading libtool-ltdl to 1.5.22-6.1 fixes the crash.

Comment 12 Bill Nottingham 2007-02-03 17:01:25 UTC
*** Bug 227131 has been marked as a duplicate of this bug. ***

Comment 13 Ralf Ertzinger 2007-02-07 12:31:38 UTC
Is there a timeframe for a fix for this?


Comment 14 Karsten Hopp 2007-02-07 12:46:59 UTC
I'm currently busy with other stuff, but will look at this as soon as possible.

Comment 15 Karsten Hopp 2007-02-08 15:41:13 UTC
libtool-1.5.22-9 should fix this

Comment 16 david.hagood 2007-02-10 22:15:52 UTC
This has been marked as "CLOSED RAWHIDE", but libtool has not been updated in
the repositories.


Comment 17 Ralf Ertzinger 2007-02-11 13:39:13 UTC
There has not been a successful rawhide build since this package was updated due
to dependency breakage (quite unrelated to this bug, I am sure).

You can use the FC6 release package for the time being.


Note You need to log in before you can comment on or make changes to this bug.