Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225104 - system-config-printer comes with "$&amp: NOT found" error
Summary: system-config-printer comes with "$&amp: NOT found" error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-01-28 23:11 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.7.52-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-15 09:54:28 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2007-01-28 23:11:30 UTC
Description of problem:

During attempts to find some reasonable driver for Samsung
ML-2250 printer (hooked via USB) the following was produced:

l\d+[aA]/$&amp: NOT found in /usr/bin:/bin
/usr/share/system-config-printer/system-config-printer.py:2781: GtkWarning:
Failed to set text from markup due to error parsing markup: Error on line 3:
Character ''' is not valid inside an entity name
  self.lblError.set_markup(error_text)

Unfortunately I cannot tell when precisely this error happened
as GUI hid all of that and the error was only found later on a console.

It could be as well something "funny" in one of ppd files; or something
interpreted data in a too enthusiastic way.  I am afraid that I do not
know (and it is not even mine rig).

Version-Release number of selected component (if applicable):
system-config-printer-0.7.49-1.fc6
foomatic-3.0.2-39.4.fc6

How reproducible:
no idea

Comment 1 Tim Waugh 2007-02-07 11:47:24 UTC
Should be fixed in CVS now.  I'll let you know when there is an update to test.

Comment 2 Tim Waugh 2007-02-08 10:24:09 UTC
Please try 0.7.50-1.fc6 from updates-testing:

yum --enablerepo=updates-testing update 'system-config-printer*'


Comment 3 Fedora Update System 2007-02-14 19:59:40 UTC
Fixed in update: system-config-printer-0.7.52-1.fc6


Note You need to log in before you can comment on or make changes to this bug.