Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225086 - FTP install fails when it starts using wrong directory on server
Summary: FTP install fails when it starts using wrong directory on server
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
: 229181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-28 20:50 UTC by Dax Kelson
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-24 21:40:40 UTC


Attachments (Terms of Use)
traceback from anaconda (deleted)
2007-01-28 20:50 UTC, Dax Kelson
no flags Details

Description Dax Kelson 2007-01-28 20:50:01 UTC
Description of problem:

I have done many sucessful NFS installs of RHEL5beta2. Today I tried a FTP
install and about 2/3rds the way through installing packages it claimed it had a
problem reading the sabayon RPM. I checked the FTP server and the package was
fine. Note that I'm "skipping" inputing a installation number.

I rebooted and tried the install again and got the same error.

The FTP server PATH is: /pub/netinstall/RHEL5

I did a packet capture and observed the following when I hit the "Retry" button
on the sabayon popup message:

  0.778021 192.168.241.128 -> 192.168.241.1 FTP Request: USER anonymous
  0.778040 192.168.241.1 -> 192.168.241.128 TCP 21 > 34766 [ACK] Seq=21 Ack=17
Win=5792 Len=0 TSV=53594358 TSER=2189332
  0.779906 192.168.241.1 -> 192.168.241.128 FTP Response: 331 Please specify the
password.
  0.780047 192.168.241.128 -> 192.168.241.1 FTP Request: PASS anonymous@
  0.780932 192.168.241.1 -> 192.168.241.128 FTP Response: 230 Login successful.
  0.781183 192.168.241.128 -> 192.168.241.1 FTP Request: CWD /
  0.781388 192.168.241.1 -> 192.168.241.128 FTP Response: 250 Directory
successfully changed.
  0.781541 192.168.241.128 -> 192.168.241.1 FTP Request: CWD pub
  0.781746 192.168.241.1 -> 192.168.241.128 FTP Response: 250 Directory
successfully changed.
  0.781919 192.168.241.128 -> 192.168.241.1 FTP Request: CWD netinstall
  0.782063 192.168.241.1 -> 192.168.241.128 FTP Response: 250 Directory
successfully changed.
  0.782219 192.168.241.128 -> 192.168.241.1 FTP Request: CWD RHEL6
  0.782392 192.168.241.1 -> 192.168.241.128 FTP Response: 550 Failed to change
directory.

Notice that Anaconda tried changing into the RHEL6 directory instead of RHEL5!

On the server I created symlink from RHEL6 to RHEL5, clicked retry and the
install continued for 5 more minutes and then bombed out. I'm attaching the
traceback for the bombout.

Comment 1 Dax Kelson 2007-01-28 20:50:02 UTC
Created attachment 146782 [details]
traceback from anaconda

Comment 2 David Timms 2007-04-05 23:52:51 UTC
Seems this is duplicated by bug 229181. Suspected cause:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229181#c2

Comment 3 David Cantrell 2007-07-24 21:40:40 UTC
This is now working correctly in RHEL 5.1 nightly builds.  Closing as nextrelease.

Comment 4 David Cantrell 2007-08-23 18:30:44 UTC
*** Bug 229181 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.