Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225058 - Unable to enter a project name
Summary: Unable to enter a project name
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: codeblocks
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-28 11:56 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-13 18:09:26 UTC


Attachments (Terms of Use)
Screenshot of problem (deleted)
2007-01-28 12:55 UTC, Paul F. Johnson
no flags Details

Description Paul F. Johnson 2007-01-28 11:56:53 UTC
Description of problem:
If I use the project creation wizard and choose wxWidgets, there is no way to
enter any details for the new project

Version-Release number of selected component (if applicable):
1.0-0.20070125svn3540.fc7

How reproducible:
Always

Steps to Reproduce:
1. Create a new wxWidgets project
2. Click go
3.
  
Actual results:
A panel opens, but there is nowhere to enter details

Expected results:
A panel opens and you can enter details

Additional info:

Comment 1 Dan Horák 2007-01-28 12:41:22 UTC
Is this problem specific to wxWidgets projects or you are seeing this behaviour
also in other projects?
Could you create a screenshot?

Comment 2 Paul F. Johnson 2007-01-28 12:55:53 UTC
Created attachment 146762 [details]
Screenshot of problem

Makes no difference as to the type of project created - you get the same
result.

Something minor on this, the wxWidget icon (when selecting the project type) is
on a line of 4 whereas the others are on lines of 3.

Comment 3 Dan Horák 2007-01-28 13:22:51 UTC
I have no such problem on FC6 with the same version of codeblocks, so it should
be related to wxGTK 2.8. I will contact upstream about this issue.

The cause for "lines" issue is that the projects are stored in columns starting
in the left.

Comment 4 Dan Horák 2007-01-28 15:22:17 UTC
It looks like a general problem, link to Code::Blocks forum is
http://forums.codeblocks.org/index.php?topic=5022.msg39306#msg39306

Comment 5 Dan Horák 2007-02-13 10:09:56 UTC
I have created a workaround, that fixes the unvisibility of the input fields.
There still remains a problem with resizing of wxStaticBoxSizer, but it should
be wxGTK problem. Officially Code::Blocks is supported with wxGTK 2.6.


Note You need to log in before you can comment on or make changes to this bug.