Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225049 - sysklogd package update turns off logging and leaves it off
Summary: sysklogd package update turns off logging and leaves it off
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: sysklogd
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-28 02:53 UTC by D. Hugh Redelmeier
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 11:29:54 UTC


Attachments (Terms of Use)

Description D. Hugh Redelmeier 2007-01-28 02:53:39 UTC
Description of problem:
"yum update sysklogd" turns off logging and does not restart it.
It looks to me as if the problem is in the sysklogd scriptlets.

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-41.fc6

How reproducible:
probably every time.

Steps to Reproduce:
1. yum update sysklogd

  
Actual results:
from then on, yum complains with an ugly python traceback because it is
attempting to log package changes.
  # /sbin/service syslog status
  syslogd is stopped
  klogd is stopped


Expected results:
syslog continues to be running

Additional info:

The preuninstall scriptlet stops syslog; that seems good.

The postinstall scriptlet tries to start it with "/sbin/service syslog
condrestart".  On the face of it, this looks good.  But if you look at the code
in /etc/rc.d/init.d/syslog, you will see the condrestart will only restart the
daemon if its lock file is present.  Since we stopped the daemon earlier, the
lock file won't be there.

Either the scriptlet should use "restart", not "condrestart", or
/etc/rc.d/init.d/syslog's condrestart code should be changed.  I don't know the
conventional meaning of condrestart, so I cannot say which is wrong: the use or
the definition.

I don't actually know what the scriptlet guard [ "$1" -ge 1 ] does, so there may
be some subtleties that I am missing.

Perhaps https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=182605 is relevant.

Even if my analysis is wrong, the symptoms (yum spewing Python tracebacks due to
syslog failure) indicate that there is a bug somewhere here.

Comment 1 Peter Vrabec 2007-01-29 14:19:38 UTC
I can't reproduce it. :-(

# rpm -q sysklogd
sysklogd-1.4.1-39.2
# service syslog status
syslogd (pid 2484) is running...
klogd (pid 2487) is running...
# yum update sysklogd
...
Complete!
# service syslog status
syslogd (pid 2552) is running...
klogd (pid 2555) is running...







Note You need to log in before you can comment on or make changes to this bug.