Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225043 - Crash from wxLog
Summary: Crash from wxLog
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Miller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 227195 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-27 21:33 UTC by Ralph Loader
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.8.3-2.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 11:39:31 UTC


Attachments (Terms of Use)

Description Ralph Loader 2007-01-27 21:33:02 UTC
Description of problem:

bittorrent-5.0.5-2 (extras, devel, i386) crashes on start-up with a segfault.

The culprit seems to be wxLog.

Version-Release number of selected component (if applicable):

wxGTK-2.8.0-2.8.0.1.3.fc7

also relevant:

wxPython-2.8.0.1-1.fc7
python-2.5-9.fc7
bittorrent-5.0.5-2.fc7


How reproducible:

Everytime.

Stack trace below.  Frames 3 and 4 look suspicious.  In frame 4 we're at:

#4  0x05fdd545 in wxLog::OnLog (level=5, szString=0xab54d0c, t=1169931715) at
src/common/log.cpp:337
337                     pLogger->DoLog(level, szString, t);

but we end up calling something completely different:

#3  0x05fe8aad in wxMBConv::MB2WC (this=0xaab2728, outBuff=0x5, inBuff=0xab54d0c
"[", outLen=1169931715) at src/common/strconv.cpp:333
333         size_t rc = ToWChar(outBuff, outLen, inBuff);



#0  0x05fe8f5c in wxMBConvUTF8::MB2WC (this=0x60a7d54, buf=0x5, psz=0xab54d0d
"", n=2) at src/common/strconv.cpp:742
#1  0x05fea417 in wxMBConv::ToWChar (this=0x60a7d54, dst=0x5, dstLen=1169931715,
src=0xab54d0c "[", srcLen=4294967295) at src/common/strconv.cpp:242
#2  0x05f9b08e in wxConvAuto::ToWChar (this=0xaab2728, dst=0x5,
dstLen=1169931715, src=0xab54d0c "[", srcLen=4294967295) at
src/common/convauto.cpp:197
#3  0x05fe8aad in wxMBConv::MB2WC (this=0xaab2728, outBuff=0x5, inBuff=0xab54d0c
"[", outLen=1169931715) at src/common/strconv.cpp:333
#4  0x05fdd545 in wxLog::OnLog (level=5, szString=0xab54d0c, t=1169931715) at
src/common/log.cpp:337
#5  0x05fde0b0 in wxVLogGeneric (level=5, szFormat=0xab4d834, argptr=0xbfb92d88
"�\212�\006\001") at src/common/log.cpp:90
#6  0x05fde12e in wxLogGeneric (level=5, szFormat=0xab4d834) at
src/common/log.cpp:98
#7  0x06c3d7a3 in wxPyLogGeneric (level=5, msg=@0xab41220) at
src/gtk/_misc_wrap.cpp:3160
#8  0x06cb7aed in _wrap_LogGeneric (args=0xa8d2fcc, kwargs=0xb6b163e4) at
src/gtk/_misc_wrap.cpp:13944
#9  0x0017514d in PyCFunction_Call (func=0xa64498c, arg=0xa8d2fcc, kw=0x5) at
Objects/methodobject.c:77
#10 0x00142ef7 in PyObject_Call (func=0x5, arg=0xa8d2fcc, kw=0xb6b163e4) at
Objects/abstract.c:1860
#11 0x001bfc55 in PyEval_EvalFrameEx (f=0xab5256c, throwflag=0) at
Python/ceval.c:3846
#12 0x001c2b7f in PyEval_EvalCodeEx (co=0xa58ef98, globals=0xa5f08ac,
locals=0x0, args=0xab5254c, argcount=2, kws=0xab52554, kwcount=0, defs=0x0,
defcount=0, closure=0x0) at Python/ceval.c:2833
#13 0x001c0d79 in PyEval_EvalFrameEx (f=0xab523fc, throwflag=0) at
Python/ceval.c:3662
#14 0x001c2b7f in PyEval_EvalCodeEx (co=0xa7506e0, globals=0xa73d68c,
locals=0x0, args=0xb6b11fd8, argcount=4, kws=0xaac1b30, kwcount=0, defs=0x0,
defcount=0, closure=0x0) at Python/ceval.c:2833
#15 0x00161fa0 in function_call (func=0xa8cfd84, arg=0xb6b11fcc, kw=0xb6b16cec)
at Objects/funcobject.c:517
#16 0x00142ef7 in PyObject_Call (func=0x5, arg=0xb6b11fcc, kw=0xb6b16cec) at
Objects/abstract.c:1860
#17 0x001bfc55 in PyEval_EvalFrameEx (f=0xab49b1c, throwflag=0) at
Python/ceval.c:3846
#18 0x001c2b7f in PyEval_EvalCodeEx (co=0xa0e2f50, globals=0xa0b8acc,
locals=0x0, args=0xb6b15138, argcount=2, kws=0x0, kwcount=0, defs=0x0,
defcount=0, closure=0x0) at Python/ceval.c:2833
#19 0x00161eca in function_call (func=0xa73ced4, arg=0xb6b1512c, kw=0x0) at
Objects/funcobject.c:517
#20 0x00142ef7 in PyObject_Call (func=0x5, arg=0xb6b1512c, kw=0x0) at
Objects/abstract.c:1860
#21 0x0014a3f8 in instancemethod_call (func=0xa8b5d74, arg=0xb6b1512c, kw=0x0)
at Objects/classobject.c:2493
#22 0x00142ef7 in PyObject_Call (func=0x5, arg=0xa908b4c, kw=0x0) at
Objects/abstract.c:1860
#23 0x001bad3c in PyEval_CallObjectWithKeywords (func=0xa8b5d74, arg=0xa908b4c,
kw=0x0) at Python/ceval.c:3435
#24 0x02edb398 in wxPyCallback::EventThunker (this=0xa911a50, event=@0xab3fec8)
at src/helpers.cpp:1472
#25 0x05f92d45 in wxAppConsole::HandleEvent (this=0xa911a50, handler=0xa911a50,
func=(void ( class wxEvtHandler::*)(class wxEvent &,)) 6141518,
event=@0xab3fec8) at src/common/appbase.cpp:320
#26 0x0603c2ff in wxEvtHandler::ProcessEventIfMatches (entry=@0xa96ab08,
handler=0xa911a50, event=@0xab3fec8) at src/common/event.cpp:1203
#27 0x0603c4d4 in wxEvtHandler::SearchDynamicEventTable (this=0xa911a50,
event=@0xab3fec8) at src/common/event.cpp:1385
#28 0x0603c593 in wxEvtHandler::ProcessEvent (this=0xa911a50, event=@0xab3fec8)
at src/common/event.cpp:1261
#29 0x0603ca70 in wxEvtHandler::ProcessPendingEvents (this=0xa911a50) at
src/common/event.cpp:1161
#30 0x05f936ef in wxAppConsole::ProcessPendingEvents (this=0xa911a50) at
src/common/appbase.cpp:292
#31 0x071400f5 in wxAppBase::OnIdle (this=0xa911a50) at src/common/appcmn.cpp:488
#32 0x05f92d45 in wxAppConsole::HandleEvent (this=0xa911a50, handler=0xa911a50,
func=(void ( class wxEvtHandler::*)(class wxEvent &,)) 14843930,
event=@0xbfb93b08) at src/common/appbase.cpp:320
#33 0x0603c2ff in wxEvtHandler::ProcessEventIfMatches (entry=@0x72e1440,
handler=0xa911a50, event=@0xbfb93b08) at src/common/event.cpp:1203
#34 0x0603c44d in wxEventHashTable::HandleEvent (this=0x72e141c,
event=@0xbfb93b08, self=0xa911a50) at src/common/event.cpp:877
#35 0x0603c5b6 in wxEvtHandler::ProcessEvent (this=0xa911a50, event=@0xbfb93b08)
at src/common/event.cpp:1265
#36 0x071403bc in wxAppBase::ProcessIdle (this=0xa911a50) at
src/common/appcmn.cpp:442
#37 0x070875ea in wxapp_idle_callback () at src/gtk/app.cpp:231
#38 0x014516e1 in ?? () from /lib/libglib-2.0.so.0
#39 0x01453442 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x0145641f in ?? () from /lib/libglib-2.0.so.0
#41 0x014567c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#42 0x02b99604 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#43 0x070a1fcc in wxEventLoop::Run (this=0xab37550) at src/gtk/evtloop.cpp:76
#44 0x071402dc in wxAppBase::MainLoop (this=0xa911a50) at src/common/appcmn.cpp:308
#45 0x02ed9f12 in wxPyApp::MainLoop (this=0xa911a50) at src/helpers.cpp:156
#46 0x02f068ce in _wrap_PyApp_MainLoop (args=0xa73ad2c) at
src/gtk/_core_wrap.cpp:30402
#47 0x00175109 in PyCFunction_Call (func=0xa23a52c, arg=0xa8d99ec, kw=0xa8dc79c)
at Objects/methodobject.c:93
#48 0x00142ef7 in PyObject_Call (func=0x5, arg=0xa8d99ec, kw=0xa8dc79c) at
Objects/abstract.c:1860
#49 0x001bfc55 in PyEval_EvalFrameEx (f=0xab3c154, throwflag=0) at
Python/ceval.c:3846
#50 0x001c2b7f in PyEval_EvalCodeEx (co=0xa175890, globals=0xa0b89bc,
locals=0x0, args=0xa8d9598, argcount=1, kws=0x0, kwcount=0, defs=0x0,
defcount=0, closure=0x0) at Python/ceval.c:2833
#51 0x00161eca in function_call (func=0xa25bbc4, arg=0xa8d958c, kw=0x0) at
Objects/funcobject.c:517
#52 0x00142ef7 in PyObject_Call (func=0x5, arg=0xa8d958c, kw=0x0) at
Objects/abstract.c:1860
#53 0x0014a3f8 in instancemethod_call (func=0xa8dbd24, arg=0xa8d958c, kw=0x0) at
Objects/classobject.c:2493
#54 0x00142ef7 in PyObject_Call (func=0x5, arg=0xa8d958c, kw=0x0) at
Objects/abstract.c:1860
#55 0x001bef71 in PyEval_EvalFrameEx (f=0xab3bffc, throwflag=0) at
Python/ceval.c:3777
#56 0x001c1d2f in PyEval_EvalFrameEx (f=0xab3bea4, throwflag=0) at
Python/ceval.c:3652
#57 0x001c2b7f in PyEval_EvalCodeEx (co=0xa750de8, globals=0xa73d68c,
locals=0x0, args=0x9de8a44, argcount=1, kws=0x9de8a48, kwcount=0, defs=0x0,
defcount=0, closure=0x0) at Python/ceval.c:2833
#58 0x001c0d79 in PyEval_EvalFrameEx (f=0x9de890c, throwflag=0) at
Python/ceval.c:3662
#59 0x001c2b7f in PyEval_EvalCodeEx (co=0xb7f1f068, globals=0xb7f6ca44,
locals=0xb7f6ca44, args=0x0, argcount=0, kws=0x0, kwcount=0, defs=0x0,
defcount=0, closure=0x0) at Python/ceval.c:2833
#60 0x001c2c03 in PyEval_EvalCode (co=0xb7f1f068, globals=0xb7f6ca44,
locals=0xb7f6ca44) at Python/ceval.c:494
#61 0x001dc496 in run_mod (mod=<value optimized out>, filename=<value optimized
out>, globals=0xb7f6ca44, locals=0xb7f6ca44, flags=0xbfb94bd8, arena=0x9db0768)
at Python/pythonrun.c:1264
#62 0x001dc54e in PyRun_FileExFlags (fp=0x9da9008, filename=0xbfb95a66
"/usr/bin/bittorrent", start=257, globals=0xb7f6ca44, locals=0xb7f6ca44,
closeit=1, flags=0xbfb94bd8) at Python/pythonrun.c:1250
#63 0x001ddc08 in PyRun_SimpleFileExFlags (fp=0x9da9008, filename=0xbfb95a66
"/usr/bin/bittorrent", closeit=1, flags=0xbfb94bd8) at Python/pythonrun.c:870
#64 0x001de36a in PyRun_AnyFileExFlags (fp=0x9da9008, filename=0xbfb95a66
"/usr/bin/bittorrent", closeit=1, flags=0xbfb94bd8) at Python/pythonrun.c:689
#65 0x001e7dfd in Py_Main (argc=1, argv=0xbfb94ca4) at Modules/main.c:496
#66 0x08048582 in main (argc=Cannot access memory at address 0x5
) at Modules/python.c:23

Comment 1 Paul Howarth 2007-01-31 17:59:43 UTC
This problem goes away if a parallel install of wxPython 2.6 is done on the same
machine (see Bug #223623) so although wx* is built with 2.6 compatibility
enabled (the default), it doesn't seem to be working (or is in fact badly broken
as the stack trace above suggests).

Comment 2 Matthew Miller 2007-01-31 18:40:12 UTC
Sorry, not meaning to ignore this. Busy. Has anyone checked with upstream wxWidgets?

Comment 3 Matthew Miller 2007-02-03 11:56:23 UTC
*** Bug 227195 has been marked as a duplicate of this bug. ***

Comment 4 Matthew Miller 2007-04-15 17:31:41 UTC
I'm building wxGTK 2.8.3 now. Can someone test to see if this is still an issue?

Comment 5 ritz 2007-04-17 09:31:50 UTC
works for me. thanks Matthew ::)

Comment 6 Matthew Miller 2007-04-17 11:39:31 UTC
Cool.


Note You need to log in before you can comment on or make changes to this bug.