Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225039 - unknown option 'notifyempty'
Summary: unknown option 'notifyempty'
Keywords:
Status: CLOSED DUPLICATE of bug 223753
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
: 224563 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-27 18:45 UTC by Nivag
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-29 13:13:33 UTC


Attachments (Terms of Use)

Description Nivag 2007-01-27 18:45:10 UTC
Description of problem:
root gets notified of error:
unknown option 'notifyempty'

According to the logrotate man page this is a valid option!

I found 2 files in /etc/logrotate.d with this parameter:

-rw-r--r-- 1 root root   71 Jan 13 05:34 cups
/var/log/cups/*_log {
    missingok
    notifempty
    sharedscripts
}

-rw-r--r-- 1 root root   68 Jan 23 06:33 sa-update
/var/log/sa-update.log {
    monthly
    notifempty
    missingok
}



Version-Release number of selected component (if applicable):
?

How reproducible:
allways

Steps to Reproduce:
automatic, daily cron job
  
Actual results:


Expected results:
no error

Additional info:

Comment 1 Nivag 2007-01-27 18:52:05 UTC
Hmm... weird!

Looking more closely: the error refers to 'notifyempty' but the files actually
appear to contain 'notifempty'!!!

Actual email below:

From root@jupiter.localdomain  Sat Jan 27 04:06:06 2007
Date: Sat, 27 Jan 2007 04:04:03 +1300
From: root@jupiter.localdomain (Cron Daemon)
To: root@jupiter.localdomain
Subject: Cron <root@jupiter> run-parts /etc/cron.daily
Content-Type: text/plain; charset=UTF-8
Auto-Submitted: auto-generated
X-Cron-Env: <SHELL=/bin/bash>
X-Cron-Env: <PATH=/sbin:/bin:/usr/sbin:/usr/bin>
X-Cron-Env: <MAILTO=root>
X-Cron-Env: <HOME=/>
X-Cron-Env: <LOGNAME=root>
X-Cron-Env: <USER=root>

/etc/cron.daily/logrotate:

error: sa-update:3 unknown option 'notifyempty' -- ignoring line




Comment 2 Scott McBrien 2007-01-28 11:46:34 UTC
version of affected logrotate RPM:
logrotate.i386 3.7.4-9.fc6


Comment 3 Peter Vrabec 2007-01-28 12:44:06 UTC
What locale do you use?

could you run 
#logrotate -v /etc/logrotate.conf
and see in which config file is the problem.

Comment 4 Peter Vrabec 2007-01-29 10:58:20 UTC
*** Bug 224563 has been marked as a duplicate of this bug. ***

Comment 5 Tom Horsley 2007-01-29 12:06:14 UTC
On my system the error comes from /etc/logrotate.d/sa-update which is owned
by spamassassin-3.1.7-4.fc5 (and the errors started the day after rpm -i
says this was installed by a yum update).

Comment 6 Peter Vrabec 2007-01-29 13:09:30 UTC
thnx. Tom,
I'm reassigning this bug to Warren Togami.

# grep notifyempty /etc/logrotate.d/*
/etc/logrotate.d/sa-update:    notifyempty

Warren rename notifyempty to notifempty , please.


Comment 7 Paul Howarth 2007-01-29 13:13:33 UTC

*** This bug has been marked as a duplicate of 223753 ***


Note You need to log in before you can comment on or make changes to this bug.