Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 225026 - pata_amd not loaded so no drives found
Summary: pata_amd not loaded so no drives found
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 226912 227441 228770 231557 233723 234583 234590 234660 234832 Installationsource 235407 236519 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-01-27 16:50 UTC by Chris Adams
Modified: 2014-03-17 03:05 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-29 17:25:22 UTC


Attachments (Terms of Use)
crash dump from install (deleted)
2007-04-09 20:01 UTC, Need Real Name
no flags Details

Description Chris Adams 2007-01-27 16:50:26 UTC
Trying a network install of 2007-01-27 rawhide, I get no hard drives found.  I
have an nVidia based mboard with an MCP2A IDE controller (PCI ID 10DE:0085). 
This is apparently supposed to be driven by pata_amd (it is listed in
modules.alias with that PCI ID), but it didn't get loaded.  If I load it
manually, my hard drive and DVD-ROM drive are found.

It did load sata_nv, but I don't currently have any SATA drives attached.

Comment 1 Jeremy Katz 2007-01-29 20:20:17 UTC
Hrmm...  are the ids with sata_nv the same?  If so, we may need to extend the
hackery we previously did for ahci/ata_piix 

Comment 2 Bill Nottingham 2007-01-29 20:25:20 UTC
sata_nv has:
alias:          pci:v000010DEd*sv*sd*bc01sc01i*
alias:          pci:v000010DEd*sv*sd*bc01sc04i*

aliases. I suppose that's mucking things up.



Comment 3 Chris Adams 2007-01-29 23:47:16 UTC
Yep, sata_nv.c has:

static const struct pci_device_id nv_pci_tbl[] = {
...
        { PCI_VENDOR_ID_NVIDIA, PCI_ANY_ID,
                PCI_ANY_ID, PCI_ANY_ID,
                PCI_CLASS_STORAGE_IDE<<8, 0xffff00, GENERIC },

Since it doesn't work with all nVidia IDE devices, that seems broken to me.  Is
there not a difference between IDE and SATA that should be here?

Comment 4 Bill Nottingham 2007-01-30 16:23:03 UTC
CC'ing relevant kernel people.

Comment 5 Jeff Garzik 2007-01-30 20:01:19 UTC
Amusingly (or perhaps not so much), NVIDIA added that generic entry in order to
handle all future devices they would produce.

The presumption being that [anaconda | hwdata | whomever] should first match the
more specific entries such as those found in pata_amd, before a generic fallback
entry.

Comment 6 Jeremy Katz 2007-02-05 21:14:18 UTC
*** Bug 226912 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2007-02-26 19:16:53 UTC
*** Bug 227441 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Katz 2007-02-26 19:50:23 UTC
*** Bug 228770 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2007-03-23 18:22:08 UTC
*** Bug 231557 has been marked as a duplicate of this bug. ***

Comment 10 Jeremy Katz 2007-03-28 19:19:44 UTC
*** Bug 233723 has been marked as a duplicate of this bug. ***

Comment 11 Chris Adams 2007-03-29 14:00:34 UTC
Are steps being made towards fixing this?  Will it be fixed within anaconda or what?

I would really say sata_nv is broke, as it claims PCI devices it cannot handle
(which is kind of the case with ahci as well since it can't handle some devices
in some modes but claims them anyway).  The "quick fix" for sata_nv vs. pata_amd
may just be to have anaconda and such choose the more specific match when
looking at PCI IDs.


Comment 12 Jeremy Katz 2007-03-29 17:25:22 UTC
After finally tracking down a machine, added code in kudzu so that the more
specific match gets picked rather than just the first.

Comment 13 David Cantrell 2007-03-30 15:25:16 UTC
*** Bug 234583 has been marked as a duplicate of this bug. ***

Comment 14 David Cantrell 2007-03-30 15:25:57 UTC
*** Bug 234590 has been marked as a duplicate of this bug. ***

Comment 15 David Cantrell 2007-04-02 15:21:26 UTC
*** Bug 234832 has been marked as a duplicate of this bug. ***

Comment 16 Jeremy Katz 2007-04-09 15:30:44 UTC
*** Bug 234660 has been marked as a duplicate of this bug. ***

Comment 17 Jeremy Katz 2007-04-09 15:31:34 UTC
*** Bug 235002 has been marked as a duplicate of this bug. ***

Comment 18 Jeremy Katz 2007-04-09 15:40:37 UTC
*** Bug 235407 has been marked as a duplicate of this bug. ***

Comment 19 Need Real Name 2007-04-09 20:01:22 UTC
Created attachment 152019 [details]
crash dump from install

Comment 20 Jeremy Katz 2007-04-16 14:03:41 UTC
*** Bug 236519 has been marked as a duplicate of this bug. ***

Comment 21 Jean Francois Martinez 2007-04-29 19:35:28 UTC
Bug is no longer present in test 4

Comment 22 Trever Adams 2007-04-30 02:29:11 UTC
I am no longer seeing the bug I reported either. I think the assessment and fix
were accurate. Thank you.


Note You need to log in before you can comment on or make changes to this bug.