Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224948 - koffice-krita: limited tablet support
Summary: koffice-krita: limited tablet support
Alias: None
Product: Fedora
Classification: Fedora
Component: koffice
Version: 6
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
Whiteboard: bzcl34nup
Depends On: 231129
TreeView+ depends on / blocked
Reported: 2007-01-27 06:26 UTC by Miles Sabin
Modified: 2008-05-06 19:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-05-06 19:06:26 UTC

Attachments (Terms of Use)
Empty Tablet preference dialog (deleted)
2007-03-06 12:14 UTC, Miles Sabin
no flags Details

Description Miles Sabin 2007-01-27 06:26:18 UTC
Description of problem:

With koffice-krita-1.6.1-4.fc6 and my shiny new Wacom tablet (which is properly
configured and works perfectly with the Gimp) the Tablet section of the
Preferences dialog appears empty and although I can use my tablet as a pointing
device I'm not able to use any of the tablet specifics (pressure sensitivity,
stylus vs. eraser tool selection etc.).

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
Actual results:

Pressure sensitivity, stylus vs. eraser tool selection etc. non-functional.

Expected results:

Pressure sensitivity, stylus vs. eraser tool selection etc. should work.

Additional info:

I have a strong suspicion that this is because of a missing BuildRequires of

Comment 1 Andreas Bierfert 2007-01-27 07:50:37 UTC
Thanks for the bug report will investigate.

Comment 2 Miles Sabin 2007-01-27 07:55:58 UTC
I've just tried rebuilding from the SRPM on a machine with xorg-x11-server-sdk
installed and still no proper tablet support, so I'm really not sure what's
going on.

Comment 3 Andreas Bierfert 2007-01-27 08:08:18 UTC
My guess would be that qt is missing the proper compile options to support it...

Comment 4 Miles Sabin 2007-03-06 12:13:08 UTC
Your guess was right, see,

However, this doesn't completely resolve the issue. With a rebuilt qt, qt-devel
and koffice-krita I now have full tablet support. However, the Tablet preference
dialog accessible from Settings => Configure Krita... is still empty.

Comment 5 Miles Sabin 2007-03-06 12:14:35 UTC
Created attachment 149331 [details]
Empty Tablet preference dialog

Comment 6 Rex Dieter 2007-03-06 14:38:58 UTC
I'd suggest taking the issue upstream to one of the koffice mailing lists and/or

Comment 7 Bug Zapper 2008-04-04 05:45:34 UTC
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out

Comment 8 Bug Zapper 2008-05-06 19:06:24 UTC
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.