Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224782 - useless comps out the wazoo
Summary: useless comps out the wazoo
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-27 03:14 UTC by Bill Nottingham
Modified: 2014-03-17 03:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-03 20:31:11 UTC


Attachments (Terms of Use)
comps filtering (deleted)
2007-01-27 06:20 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2007-01-27 03:14:11 UTC
Description of problem:

In the Desktop spin we still have choices for KDE (which will install
im-chooser and desktop printing), XFCE, Engineering and Scientific,
development, virtualization (without virt-manager!), all of Servers...

It's just an awful user experience at the moment - we offer them all
these choices that do nothing.

Not sure how to quickly fix this, though.

Version-Release number of selected component (if applicable):

20070126 desktop spin

Comment 1 Jesse Keating 2007-01-27 03:23:38 UTC
Anaconda is supposed to not show catagories/groups that have no available
packages.  In some cases, like KDE, there is one or two packages in that group
that are also in the GNOME group, so KDE is "available".  In other cases,
anaconda just isn't hiding it like it is supposed to, or so thats my theory.

We need to make some more generic groups, or move things out of gnome/kde and
into base-x which they both need, or something like that.

Comment 2 Jesse Keating 2007-01-27 03:48:39 UTC
So virtualization we're getting because we include kernel-xen (so that you can
run Desktop under xen).  We should just add virt-manager to the desktop,
especially as it grows qemu support.

We get Development, because it includes the development-tools group, which as
binutils listed in it, and we get binutils because anaconda-runtime requires
/usr/bin/strip.  So, I think we might be able to drop anaconda-runtime (and
anaconda) from the manifest.  The stuff we need that those requires could be
listed or pulled in on their own somehow.  We also get it for gdb, which
bug-buddy hauls in.  Make is there because of nss_db, pkgconfig is there for a
LOT of packages (anything with a .pc file requires pkgconfig for the directory
ownership issue), I could go on a bit here... :/

I suspec that many of these that pop up are because we have one or two things
that are show up in other groups that we have in our manifest or getting pulled
in via deps.  *sigh*

Comment 3 Bill Nottingham 2007-01-27 06:20:19 UTC
Created attachment 146740 [details]
comps filtering

As sent in mail, here's a different solution - filter comps based on a short
filter file, that excludes certain groups/categories you don't want to see.
This allows you to include one or two things from development in your manifest
without actually showing the group.

Comment 4 Bug Zapper 2008-04-03 18:59:26 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 5 Jesse Keating 2008-04-03 20:31:11 UTC
We no longer have a 'desktop' spin, so this bug doesn't really matter anymore.


Note You need to log in before you can comment on or make changes to this bug.