Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224643 - kernel-2.6.19-1.2895 locks up during startup
Summary: kernel-2.6.19-1.2895 locks up during startup
Keywords:
Status: CLOSED DUPLICATE of bug 225399
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-26 20:42 UTC by Erik Horn
Modified: 2011-12-13 22:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-15 20:24:51 UTC


Attachments (Terms of Use)

Description Erik Horn 2007-01-26 20:42:08 UTC
Upgrading to kernel-2.6.19-1.2895.fc6 causes system to crash during startup.
This happens reliably with two machines, both Dell Poweredge 2950's.

Booting with the 2.6.18-1.2869 kernel works fine.

Last line on the console during bootup was:

Starting HAL daemon: do_IRQ: 0.161 No irq handler for vector

/var/log/messages indicates that ahavi-daemon completed startup but there were
no messages relating to HAL.

Two startups with the bad kernel both seemed to crash as the same place

Comment 1 Paul Miller 2007-02-01 23:33:36 UTC
same issue
kernel-2.6.18-1.2868.fc6
kernel-2.6.18-1.2869.fc6
both work

kernel-2.6.19-1.2895.fc6 fails to boot
do_IRQ: 0.161 No irq handler for vector

Dell PowerEdge 1950 x86_64

messages from kernel-2.6.18-1.2869.fc6
Feb  1 16:34:33 newmachine syslogd 1.4.1: restart.
Feb  1 16:34:33 newmachine kernel: klogd 1.4.1, log source = /proc/kmsg
started.Feb  1 16:34:33 newmachine kernel: Bootdata ok (command line is ro
root=LABEL=/)Feb  1 16:34:33 newmachine kernel: Linux version 2.6.18-1.2869.fc6
(brewbuilder@hs20-bc1-5.build.redhat.com) (gcc version 4.1.1 20061011 (Red Hat
4.1.1-30)) #1 SMP Wed Dec 20 14:51:34 EST 2006
Feb  1 16:34:33 newmachine kernel: BIOS-provided physical RAM map:

messages from kernel-2.6.19-1.2895.fc6
Feb  1 16:40:57 newmachine syslogd 1.4.1: restart.
Feb  1 16:40:57 newmachine kernel: klogd 1.4.1, log source = /proc/kmsg
started.Feb  1 16:40:57 newmachine kernel: Linux version 2.6.19-1.2895.fc6
(brewbuilder@ls20-bc2-14.build.redhat.com) (gcc version 4.1.1 20070105 (Red Hat
4.1.1-51)) #1 SMP Wed Jan 10 18:50:56 EST 2007
Feb  1 16:40:57 newmachine kernel: Command line: ro root=LABEL=/
Feb  1 16:40:57 newmachine kernel: BIOS-provided physical RAM map:

I can attach full /var/log/messages if helpfull

thanks


Comment 2 Jeff Genender 2007-02-14 20:21:00 UTC
Same problem here - Dell 2950 - Quad Core Intel X5355 4G RAM.  This happens on
2.6.19-1.2911 kernel as well.

do_IRQ: 0.161 No irq handler for vector


Comment 3 Jarod Wilson 2007-02-14 22:16:41 UTC
I suspect the fix is the same as for bug 225399. My problems were less severe, but similar, and resolved 
by the patch Chuck referrences in that bug. If so desired, I can make my patched kernel available for 
testing (the patch requires some rediffing to get it to apply, mostly because of xen).

Comment 4 Chuck Ebbert 2007-02-15 20:24:51 UTC

*** This bug has been marked as a duplicate of 225399 ***


Note You need to log in before you can comment on or make changes to this bug.