Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224635 - kickstart doesn't create LVM vol for swap
Summary: kickstart doesn't create LVM vol for swap
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-26 20:08 UTC by Doug Chapman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-04 20:48:30 UTC


Attachments (Terms of Use)

Description Doug Chapman 2007-01-26 20:08:37 UTC
Description of problem:
During a kickstart install it complained the swap lvm volume doesn't exist:


     Error enabling swap device VolGroup00/LogVol01:
     No such file or directory

     This most likely means this swap partition has
     not been initialized.

     Press OK to reboot your system.


here is the partitioning secion of my kickstart file:

clearpart --all
part /boot/efi --fstype vfat --size=100 --ondisk=sda
part swap --size=2000 --grow --ondisk=sdb
part pv.30 --size=0 --grow --ondisk=sda
volgroup VolGroup00 --pesize=32768 pv.30
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=992 --grow
--maxsize=1984



Version-Release number of selected component (if applicable):
rawhide-20070125
anaconda-11.2.0.17-1
lvm2-2.02.19-2.fc7


How reproducible:
100%

Steps to Reproduce:
1. kickstart install with partitioning scheme shown above
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Doug Chapman 2007-01-26 21:40:32 UTC
If I remove the /dev/sdb swap partition from my kickstart conf (the swap
partition that is not under lvm control) the install works.

learpart --all
part /boot/efi --fstype vfat --size=100 --ondisk=sda
# part swap --size=2000 --grow --ondisk=sdb
part pv.30 --size=0 --grow --ondisk=sda
volgroup VolGroup00 --pesize=32768 pv.30
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=992 --grow
--maxsize=1984


Perhaps something is telling lvm to look at /dev/sdb?  




Comment 2 Chris Lumens 2007-01-29 16:52:43 UTC
Are there any messages on tty1 or tty3?

Comment 3 Doug Chapman 2007-01-29 17:11:47 UTC
This was a serial console install so there wasn't any easy way to get at this. 
If I get caught back up with RHEL5 testing today I will reprodue and get more info.



Comment 4 Chris Lumens 2007-01-29 20:31:06 UTC
/dev/VolGroup00/ is disappearing when the swap filesystems are being formatted,
I believe in swapFileSystem.labelDevice, in fsset.py.  Investigating...

Comment 5 Chris Lumens 2007-01-29 20:53:49 UTC
Peter's fixes to partedUtils.py on the rhel5 branch appears to fix this problem.
 He just needs to port those changes over to head.

2007-01-09  Peter Jones  <pjones@redhat.com>

        * partedUtils.py (DiskSet.openDevices):
        - Revert ksdata.clearpart["done"] patch
        - Move stuff to helper functions
        - only initialize disks once (#220021)
        - hopefully, make the code a little bit more readable


Comment 6 Doug Chapman 2007-04-23 18:53:48 UTC
FYI, this is still broken in the same manner.  I don't know if it was fixed and
then regressed since I have been out for the past 2 months.

I am currently using rawhide-20070419 on ia64 which includes:
anaconda-11.2.0.52-1
parted-1.8.6-4.fc7



Comment 7 Chris Lumens 2007-05-04 20:48:30 UTC
This should be fixed in the next build.  Our LVM device nodes were getting
removed due to overzealous use of lvm.vgdeactivate.


Note You need to log in before you can comment on or make changes to this bug.