Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224619 - anaconda dies if "langsupport" is in kickstart file
Summary: anaconda dies if "langsupport" is in kickstart file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-26 18:35 UTC by Doug Chapman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-26 18:40:42 UTC


Attachments (Terms of Use)

Description Doug Chapman 2007-01-26 18:35:02 UTC
Description of problem:
Using an older kickstart file that has a "langsupport" line in it causes
anaconda to die.  It should handle this with a warning.


Traceback (most recent call last):
  File "/usr/bin/anaconda", line 710, in <module>
    vncksdata = setVNCFromKickstart(opts)
  File "/usr/bin/anaconda", line 279, in setVNCFromKickstart
    ksparser.readKickstart(opts.ksfile)
  File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 488, in
readKickstart
    self._stateMachine (lambda: fh.readline())
  File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 401, in
_stateMachine
    self.handleCommand(lineno, args)
  File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 257, in
handleCommand
    self.handler.dispatcher(args[0], args[1:], lineno)
  File "/usr/lib/python2.5/site-packages/pykickstart/commands/base.py", line
247, in dispatcher
    raise KickstartParseError, formatErrorMsg(lineno, msg=_("Unknown command:
%s" % cmd))
pykickstart.errors.KickstartParseError: The following problem occurred on line 6
of the kickstart file:

Unknown command: langsupport

Version-Release number of selected component (if applicable):
rawhide-20070125
anaconda-11.2.0.17-1

How reproducible:
100%

Steps to Reproduce:
1. do a kickstart install that has the following line in the kickstart file:
langsupport --default=en_US.UTF-8 en_US.UTF-8

2.
3.
  
Actual results:
traceback

Expected results:
warning about the langsupport line



Additional info:

Comment 1 Chris Lumens 2007-01-26 18:40:42 UTC
I marked this command as deprecated in FC5, and since it's now two releases and
people have had plenty of time to see the warning, I have removed it.  If you
need to process kickstart files for pre-F7 releases, pykickstart does provide a
mechanism for that.


Note You need to log in before you can comment on or make changes to this bug.