Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224590 - Error in post uninstall script
Summary: Error in post uninstall script
Keywords:
Status: CLOSED DUPLICATE of bug 205769
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-26 15:42 UTC by Phil Knirsch
Modified: 2015-03-05 01:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-27 12:46:23 UTC


Attachments (Terms of Use)

Description Phil Knirsch 2007-01-26 15:42:41 UTC
During an automated install/deinstall check the following error has happened:

ERROR: Output running post uninstall script for package rpm-0:4.4.2-39.fc7.i386
groupdel: group rpm does not exist

Redirecting the userdel and groupdel commands to /dev/null fixes the problem.

postuninstall scriptlet (using /bin/sh):
if [ $1 = 0 ]; then
    /usr/sbin/userdel rpm > /dev/null 2>&1
    /usr/sbin/groupdel rpm > /dev/null 2>&1
fi
exit 0

Comment 1 Jeff Johnson 2007-01-27 03:49:35 UTC
DUPE of #205769

Comment 2 Panu Matilainen 2007-06-27 12:46:23 UTC

*** This bug has been marked as a duplicate of 205769 ***


Note You need to log in before you can comment on or make changes to this bug.