Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 224546 - yum "package-cleanup --problems" barfs
Summary: yum "package-cleanup --problems" barfs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-26 10:20 UTC by James Hunt
Modified: 2014-01-21 22:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 19:10:22 UTC


Attachments (Terms of Use)

Description James Hunt 2007-01-26 10:20:03 UTC
Description of problem:

# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 349, in ?
    main()
  File "/usr/bin/package-cleanup", line 346, in main
    provsomething = buildProviderList(my,pkgs,opts.problems)
  File "/usr/bin/package-cleanup", line 85, in buildProviderList
    resolve_sack = my.rpmdb.whatProvides(req,rflags,ver)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 390, in whatProvides
    pkgs = self.searchProvides(name)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 141, in
searchProvides
    return self.searchPrco(name, 'provides')
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 123, in searchPrco
    if not result.has_key(po.pkgid):
TypeError: list objects are unhashable

Version-Release number of selected component (if applicable):

yum-utils-1.0.1-1.fc6

How reproducible:

Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2007-04-25 19:10:22 UTC
This is fixed up for F7; it's caused by a package which was built with an
incredibly ancient version of rpm


Note You need to log in before you can comment on or make changes to this bug.